Sony DW-D22A crossflash to DRU-710A procedures?

I keep getting a ‘gateway timeout’ for the codeguys links. I need the Firmware: Sony DRU-710A "BYX5 - patched - crossflashing, multi-colored LED file. Does anyone have a copy I can get elsewhere please?

http://codeguys.rpc1.org/firmwares.html#DRU-710A

Still getting a ‘gateway timeout - server unreachable’ error from this link:
http://codeguys.rpc1.org/firmwares.html#DRU-710A. Any suggestions?

Works fine with IE and Firefox.

What do you use.

Using IE on cable internet here in Canada. No proxy & no router being used. Perhaps my ISP is blocking this for some reason. Still cannot connect to codeguys.org. I’ll try later at work to see if I can connect from there.

Just installed the BYX5 firmware on my DW 22a and now it won’t recognise any Dvd’s whatsoever!
I used omnipatcher so I made a back up of the original - used it trying to get back to where I was before and it’s just the same ie still recognised by windows as a 710a and still won’t recognise any Dvd’s? Now going to try installing the BYX3.

Have managed to reinstall th BYX3 firmware - rebooted and everything seems as it did before, windows recognises it as a sony dw d22a etc but it still won’t recognise dvd’s cd’s seem fine here is what I did chronologically:-

using Eeprom I made a back up

using Omnipatcher I flashed the drive with BYX5 also clicked on apply recommended media settings
seemed to go ok but everything messed up

restart - still the same

reflashed drive with Ltnfw BYX3 and write boot sector checked - used compare everything ok

reboot

Using omnipatcher clicked on apply recommended media settings

reboot

as is cd’s fine but still can’t read dvd’s

Can I use Mtkflash - it says not suitable for ntfs partitions?

wish I’d never bothered trying to update.

Could the drive read/write dvd, before crossflashing.

Yes no problems, well - I just bought some x16 dvd’s and couldn’t write any faster than with x8 disk’s. I wrote two, the first one went as per usual ; approx 1/2 an hour Inclusing verifying (I find I get errors if I try to write any faster than x4) and the second took about 1 hour, 3/4’s of that time was spent verifying - so I thought I’d try updating the firmware to BYX5.

Have just reflashed the drive using the patched firmware directly, with the same results; ie It doesn’t recognise Dvd’s retail or otherwise but cd’s seem fine.

Have since tried flashing the firmware using Mtkflash but to no avail, tried the latest version and 180.1 (without the b switch) as primary master and secondary master. The Sony DW D22a is not listed as being supported by Mtkflash but the person who wrote the following thread managed to get it to work eventually.

According to this thread: http://forum.rpc1.org/viewtopic.php?t=33056&highlight=sony++d22a+mtkflash

There might be some method involving jumpers (see the last post of the thread) that can be used, I have noticed 6 pins similar to the jumpers on the other side of the audio connections to the jumpers, I don’t know if that is what he means when he says “other pins jumpered”. I would appreciate it if someone could provide more information.

Just to keep you updated: I actually got the drive to recognise a blank Dvd, I guess it’s a bit of a hit and miss affair, a lot more miss that hit! - Come to think of it I have always had problems getting the drive to accept blank Dvd’s In the beginning it was barely noticable but has got gradually worse over the 18 months and 350 disk’s I have burnt with it; with a more rapid decline just recently.
Can anyone tell me does this point to the end of the drives life or would just a clean help? For the record am now running BYX5.
Just tried burning with nero, the drive went into a continuous loop, seemingly hunting for the beginning of the disk, (before BYX5 it would try a couple of times before stopping and seemingly ready to burn a cd) every 20 seconds or so freezing the computer including process explorer for about 5 seconds (process explorer would skip the five seconds allthough i could just see it was “interrupts” causing it). Eventually locking the drive, had to use process explorer to kill nero with a reboot neccessary to bring the drive back to life.
Thanks in advance.

have you tried crossflashing to liteon 1653S?
http://codeguys.rpc1.org/firmwares.html#SOHW-1653S
http://club.cdfreaks.com/showthread.php?t=157412

No I haven’t but will look into it. But which one should I use - there is about six listed and what are the fb and fbx’s etc.
Just wrote a disk, at x4 no problems and even a good burn. but crashed on the next one and had to reboot to refind the drive.

download this one: http://codeguys.rpc1.org/firmwares/dvdrw/1653S.CS0T.patched-cf-fbdx.rar
and use the file: 1653S.CS0T.patched-cf-fbdx-mcled.exe

it’s probably the best firmware for your drive. you should also download C0deKing’s EEPROM utility and “Reset Learnt Media”: http://club.cdfreaks.com/showthread.php?t=112103

I doubt that crossflash would cure a drive, that probably are close to RIP.

The symptoms as Lofkool decreibe sounds like a drive close to it’s dead.

Which one should I use Choko? the 1653sCSOT.patched-cf-fbdx (the link above) or the 1653sCSOT.patched-cf-mcled I can’t find the file you reccommend under the above link 1653s.CSOT.patched-cf-fbdx-mcled - it’s either fbdx or mcled I can’t see both?

Oh I c, never mind their both in there.