Sony DW-26A with lite-on 1673S Firmware - CAN'T DISABLE THE REGION COUNTER

vbimport

#1

Hi, i’ve got a sony dvdRW but i can’t get the region counter off. At the first time it works but i think the dvd region free program screw it when try get it installed. And suddenly, not just the counter was enable but the counter shows that there was 2 and only 2 region changes left.

The LtnRCP it’s not working anymore, and i don’t know what else to do. I’ve restore de win registry, and changed the original firmare, but nothing.

What can i do.

Thanks

Jeremy, WITH A JAY.


#2

I had this problem
No matter what you do in LtnRPC, it still appears to be on.

Did you flash your drive while RPC was off, because this causes what u describe.

Basically to fix it, you need to go to ltnRPC, ENABLE RPC. Then reflash your drive. And then DISABLE RPC. And to avoid the problem, just remember to enable rpc before you flash your drive before disableing it again.


#3

no, i replace the sony original firmware with the lite-on one as a desperate recovery solution. The ltnRCP stops its functionability before i flashed the drive. Do you think that the reflash will fix it? Do you mean, reflash with the same Lito On Firmware?

Thanks

Jeremy, WITH A JAY.


#4

Have you removed the dvd region free program?


#5

Can you be more specific as to what you mean when you say that LtnRPC is not working? Exact error messages and observations of what it does and doesn’t do…

Also, have you read this? (linked to from the FAQ)


#6

I’ve removed de dvd region free program, i ran the ltnRCP again and the message is the same, “invalid field CDB RCP may be disabled” I read that it’s fine. But when i check in the drives properties the dvd region it’s still enabled.


#7

It sounds like that LtnRPC is working perfectly fine… LtnRPC only disables the region protection on the hardware/firmware side… check the link in my post above.


#8

ok, thanks a lot for your help guys!!! But ONE last thing, Does anyone of you know how to get back my Sony firmware? I read that it’s not easy to find… or, is there any problem to have the lite-on firmware?, i mean how the firmware affect to the hardware?

Thanks!

Jeremy, WITH A JAY.


#9

There’s really no reason to keep using JYS2; it’s old and the Sony DW- firmwares are never well-supported. The main difference, aside from it being outdated, is that the name is different, but that doesn’t affect performance.


#10

Yeah thats the exact same problem i had. LtnPRC says its disabled, but the crap still appears in device properties. This always happens if i flash while its disabled. I fixed it by enableing RPC in ltnRPC and flashing, then disable. I don’t know if this will work for you.


#11

Thank you all!

I’ll try that.

Jeremy, WITH A JAY.