Sony DVDRW Optiarc weird problems (Optiarc AD-7190A)

vbimport

#1

Hello everyone, this is my first post so sorry in advance if this is not the right forum to seek help about this problem.

I bought an Optiarc AD7190A a month ago which randomly would read or burn cds or dvds on my computer (mother ASUS A7V8X-X), most of the times would fail. Because of this, I tried the burner on my work: it worked flawlessly on 2 computers, reading and burning cds and dvds. Both computers had even worse performance than mine in general. Mine is an Athlon XP 2000+ and those where Pentium III and Semprons I think.
Well, I tried again the burner on my computer, this time I randomly changed the PIO mode in the bios from Auto to 0, and DMA mode from Auto to 1. I booted, and the burner worked PERFECTLY on Windows 2000 SP4. I even upgraded the firmware.

The problem is that the burner still does not work on Linux/UNIX (Ubuntu, Fedora, FreeBSD, you name it), it behaves like it when it was in Auto mode. I/O errors.

What are these PIO and DMA modes? what should I try and why the “Auto” options of my motherboard didnt work well even to Windows? How to make the burner work on Linux/UNIX like it does on Windows now? The burner its working for hardware as secondary master.

Thanks in advance.


#2

Maybe you could replace the ide cable (with an 80 wire ide cable) and try again?


#3

Its worth a try on what Chef said. Unistalling the drive in the device manager and then rebooting computer let windows reinstall the drive might help to without using a new cable.