Sony DVD RW Q30a, problems working

vbimport

#1

I just had one of my friends put together a new computer for me from components that I ordered from newegg.com

The DVD drive that I bought for it was a Sony DVD RW Q30a, and it seems to have trouble reading blank CD-Rs. When I insert a CD-R into the drive, and then try to access it, I get the error message “E:\ is not accessible. Incorrect function.” The icon for the drive changes to a CD-R icon when the CD-R is in it, though.

I have no idea what to do or what the problem is. The drive seems to be able to read regular CDs and DVDs perfectly fine.

Thanks in advance for any help you guys can give me.


#2

Fredafe3c4, welcome to cdfreaks. :slight_smile:

Can you clarify for me what the CD-R you are inserting contains and when you say regular CDs, what is on this disc also.

One thing you can try is; using Device Manger delete the IDE channel driver the drive is connected to (usually the secondary IDE) and then reboot.


#3

The CD-R’s when i say regular, i mean anything else really, a orginal music cd, or data cd containing mp3/mpegs etc.
One thing it does do though i write to cd-r’s when using roxio, but cant write dvds. although i actually only have dvd+r not dvd-r, but shud it not be able to write on both?
Oh and i tried deleting IDE channel driver, didnt solve the problem, does same as before. I do have another dvd/cdrw drive installed if this makes any difference?


#4

Just to be sure, make sure the Sony DVD RW is the only drive on the secondary IDE channel, as master and then delete the IDE driver again and reboot.

The drive should be able to burn all of the DVD media types (±R/RW/R9) and they are a good drive as well. Make sure you have the drive using the latest YYS6 firmware. You’ll find it in the firmware announcement “read first” thread .


#5

Ok well it’s still doing the incorrect function thing, but it is now working in nero thanks to the a new reinstall of IDE channel and some new firmware so its all good, thanks for your help.


#6

I hav a problem that when i try burning a DVD it takes like 50 MINS 2 do it and i my CPU usage is at like 2% i exit all applications like msn messenger and disable norton. It burns at like 1.3X speed and i have a SONY DW-Q30A
before it usulay burnt relaly fast like a DVD in 15 20 mins now it take slike 50 mins:S:S
whats wrong


#7

Baller, check your DMA is enabled in both the BIOS and Windows.
http://club.cdfreaks.com/showthread.php?t=101616

Sometimes you need to delete (using Device Manger) the IDE channel driver that the drive is connected to and then reboot.


#8

Heyy i just did that and then i uninstalled my secondary ide drive ( dvd sony dw-q30a) using DEVICE MANaGER and i rebooted. It installs itall over agian
and i am still having the same problem?
whats wrong


#9

What about this bit. :wink:


#10

how do i change it in BIOS tho?
thats wierd before it was going fast how can it change now?


#11

Alright nevermind i tried changing in BIOS i put it 2 AUTO for DMA
yet this is still taking long to burn it took like 40 mins just 2 burn a 3.2 gig dvd movie. ANd i disable norton and i exit msn an dthere are no other applictaions going on. It never took this long before:S:S it usualy finishes in about 15-20 mins
And my Firmware is at yys1 i think. if that helps