Sony DVD-RW problem

vbimport

#1

Hi, i made an account here specifically for this although i have been reading the forums for a long time . I just got my old sony dvd-rw replaced with a new Sony AD-7200A drive .
For the first week since its arrival , i might have burnt just 1 dvd as i had my exams :o
So , it was yesterday, which is almost 3 weeks after i got it, i tried burning a dvd . It took almost 45 minutes to burn the dvd . I use Nero 7. I burnt a normal data-dvd on 12x which should have taken me around 10-15 mins. But it took around 45 minutes. I thought it might have been a problem with the disc . So after the agonizing wait, the burn session was over and thankfully the dvd was properly burnt. Then i put in a new blank dvd and tried burning something on it . The same thing happened again . It takes ages to burn a normal dvd .
Any suggestion would be great. :confused:


#2

Hi skitzz, welcome to CDF :slight_smile:

Have a look at the link in my signature, “How to check/enable DMA”, as this sounds like a symptom of DMA not being enabled for the drive.


#3

Hi Arachne thanks for the reply. Well , i read the guide you referred to . I used the 3rd method mentioned out there … the one where you have to select DMA if available on the 4 ide channels in device manager. I dont remember correctly , but the dma mode was not selected on 1 of the 4 channels. Cant remember which 1 precisely sorry:(
That did not solve the problem though. Im burning a dvd as i write this and its going superslow. The process has been on for nearly 20 minutes and it still shows 19 mins remaining . Plus, it is hogging up a lot of system memory. All the other things work damn slow. I never had such a problem in the past.
I have even tried different burning softwares like the Cheetah DVD burner and the Ashampoo Burning studio. They take the same amount of time(and system resources :a)

Im not on a rather quick computer. My specs are … 2.7ghz p4 1gig ram.

Ive never had such a problem in the past, its just since ive got this new burner has this problem started.:sad::sad:


#4

OK, let’s try another way, this way should work nicely as I’ve used it myself on my mum’s PC :slight_smile:

Download the script “resetdma.vbs” from this post and run it.

If it finds a channel that needs resetting to UDMA mode, it’ll change it, then you’ll have to reboot.

That should fix it. Good luck! :slight_smile:


#5

lol how do u run a vbs file? I know it is a visual basic thing , but when i double click it , it wont execute .
I did google as well , all i could muster were a couple of dead links :doh:
help here as well please lol:p


#6

Weird, it should execute when you double click it.

Unless you’ve got some security software (anti-virus) which has script-blocking enabled, that would stop it running.

Can you re-check your IDE channels and tell me which one is in PIO Mode?

Looks like we’ll have to do this the manual way :wink:


#7

Hey i changed the transfer mode for all the 4 channels into “DMA if available”.
But , i just checked all of them again now , and the Current Transfer Mode for the 2nd Primary IDE Channel is set to PIO mode. hope this helps

Maybe i dont have the Windows Script thing … that is whats preventing the .vbs file from running


#8

Ouch, Primary IDE. Usually if it’s the Secondary IDE channel in PIO Mode, uninstalling it and letting Windows re-detect it shouldn’t be a problem.

In the past, I’ve uninstalled my own Primary IDE channel in Device Manager (right-click -> Uninstall) with no ill-effects (Windows just re-detects it after a reboot, and puts it into DMA Mode).

However, if your OS (Windows) drive is on your Primary IDE channel, do this at your own risk. As I say, I didn’t have a problem, but you never know.

You might want to wait and see if someone can help you run the .vbs file (have you tried right-clicking on it and opening it that way?)


#9

No i couldnt find any suitable program to run it with . I just downloaded the Windows Script from the ms website…
Ill restart the computer and then ill try running the vbs file


#10

Hope that does the trick :slight_smile:

If it doesn’t, can you try disabling your anti-virus software then running the file?


#11

Hey , i managed to run the vbs file through cscript. I rebooted my computer after that. Next , i burned a test dvd with data amounting upto 1.5 gb. But this time i burnt it on 16x. It took nearly 6 mins. That seems to be an improvement, isnt it?
But as usual , nero is using a huge chunk of my ram . I opened task manager and in the processes tab i found that nero was using around 280 mb ram:eek:


#12

Hmmm. Nearly 6 mins for only 1.5 GB of data still doesn’t sound right…unless the drive dropped the speed due to disc quality or something.

Do me a favour? Re-check your IDE channels in Device Manager, and make double sure none of them are still in PIO Mode (though I doubt they are now, it’s always worth checking).

That’s a lot of RAM for Nero to be hogging. I’d try one of the other softwares you mentioned and see if that’s a bit leaner.


#13

No they’re all on DMA now .
Yes , ive removed Nero and installed Ashampoo. Damn it , ive run out of blank dvds :sad:


#14

OK, no PIO Mode to be seen? That’s excellent :slight_smile:

If the problem comes back, just re-run the file (you might like to keep it on the desktop or somewhere handy).

Doh, Sod’s Law that you’d run out of discs when trying to troubleshoot a problem. Sort of thing that would happen to me :wink:

But hopefully it’s solved now :slight_smile:


#15

lol.
But still , something just isnt right. Even when i use my antispyware , it uses way too much ram than what it usually does. And the speed hasnt improved either.
Ill burn a fresh dvd tomorrow and ill post the updates here.

You’ve been of great help so far. Thanks soo much:bow:


#16

You’re welcome :slight_smile:

Regarding the overall system speed, only thing that I could put that down to, is your HDD is still in PIO Mode (but you checked that), or needs a good defragging. You have ample RAM - my other system had 1 gig before I added more, and that was good enough.