SONY DVD+-RW DW-Q58A only burns at 0.8x

vbimport

#1

hi everyone!

i already searched the forums, but didn’t find a solution.
i have the above mentioned drive in my dell inspiron 9400/1705.

problem
i can burn dvd and even cd at a speed of only 0.8 or something like that. i tried different media. last one was fuji dvd+r (16x). dvd-identifier told me i can burn this media at 8x.
i also tried different software (nero7, alcohol). always the same. no difference between audio-cd/data-cd/image-burning.

firmware: UDS2 (shipped with it)

another unusual thing: i can’t change the firmware. i tried “UYS3WIN.EXE”.

output: “no matched drive detected! - this utility is only for SONY DVD RW DW-Q58A drive. Detected drives: 1-0-0-0 E: SONY DVD±RW DW-Q58A UDS2” :confused:

another thing noticed: some discs cause the laptop to use all resources for the drive. when this happens, i can’t even start a program. it’s extremly slowed down.

does anybody has a suggestion. or maybe someone had the same problems?

greetings and thanks in advance


#2

Hi and Welcome!

Please check if DMA is enabled. I suspect, it is not.

Michael


#3

How to check DMA. http://club.cdfreaks.com/showthread.php?t=101616


#4

The apparent “lock-up” could be caused by the drive running in PIO mode as this mode uses a great deal of CPU resource to write. The thread you’ve been pointed to should help.


#5

hi!

thanks for the answers. but this is not the reason. both, primary ide and secondary ide are at “DMA if available”. my hd is sata, don’t know if this has anything to do with it …


#6

while burning i can’t even listen to mp3 on winamp … full of hacks …


#7

What’s the ‘Current Transfer Mode’ for harddisc and optical drive.

It should be ‘Ultra DMA mode’, must not be ‘PIO mode’.


#8

primary ide-device 0 current transfer mode is at "ultra dma mode 5"
primary ide-device 1 current transfer mode is at “not available”

secondary ide-device 0 WAS at "pio"
secondary ide-device 1 current transfer mode was at “not available”

although “dma, if available” is selected, the channel only had “pio”. i tried to fix it using this post:

http://www.cdrlabs.com/phpBB/viewtopic.php?t=6645

first, i set the channel to “pio” - reboot - then i set the channel again to “dma, if available” - reboot - same shit as before, nothing changed.

then i deleted the secondary ide - reboot - another problem occured :sad: windows can’t reinstall the driver for the secondary ide. each reboot i am told, that new hardware is found (the 2nd ide), but the drivers could not be installed (neither automatically nor manual method functioned). i got xp pro sp2 (all updates installed).

now there is a yellow sign on the ide-channel in my device manager. :doh:

and now the curiosity: i can see and open data on my dvd drive in windows-explorer

don’t know what to do … any idea?


#9

This is really not a good idea anyway. Did you try burning without all other processes shut off?


#10

Edit:
Try uninstalling the drive itself in Device Manager and reboot.


#11

the chaotic situation endend up in re-installing windows. :sad: when i tried to go back to a system-restore-point restarting ended up in blue screen. also repairing via windows cd didn’t do the job. i hate it when such things happen. :a thanks anyway for the suggestions. after re-installing every ide-channel is at dma transfer.