Sony DVD RW DW-G120A problem

vbimport

#1

hi i recently changed my cpu cooling fan and my DVD drive is not working. the drive shows up as recognised during boot sequence, i can eject/load cds using software but it does not play any disks.

in the dos mode it says drive not ready.

can some one please let me know what can be the problem. i also upgraded the firmware to mys6. thanks


#2

Knocked the IDE connector out during the install?


#3

hi the cables are fine, the strange thing is bios recognises though it shows the name as a scsi drive, explorer can see the drive but the media is not getting recognised. thanks


#4

The only reason I could imagine that a DVD Drive is recognised as scsi was that it was on a RAID controller with the config set to RAID - Windows detects RAID controllers as scsi controllers.

Check that your bios has your Raid setup as standard IDE, and not as RAID.


#5

Go to Device Manager uninstall the IDE controller that this drive connected to it reboot and let the windows install the burner and the driver for it.


#6

Hi did remove the controller and let it reisntall but the result is the same. will open the machine later to check cables again. thanks


#7

hi i did change the cable slots and now am able to get the cd drive recognised as ide drive but still not able to use it. in the dos mode it says device not ready. have uninstalled nero and power dvd to avoid any issue due to filters.

net net i am still stuck. can some one please advise.


#8

Do you have any other programs (launchers) which access the disk drive, things like creatives disk detective? Anydvd? DVD43? & etc?


#9

debro thanks. i removed all of them. i also remove the upper class and lower class filte4rs as well.cleaned the registry as well.till no result. thanks


#10

Dos mod eis unimportant here.

What does PowerDVD say when you try to play a VideoDVD?
Which PowerDVD version is it?


#11

hi thanks. when i had power DVD and run it will not do any thing. i am not sure wahat version it was.


#12

Probably you need to properly uninstall such tools, restart and try again.

Try with VLC Tool.


#13

hi sorry for the long silence. after a lot of hours in trying to fix i still have not made a whole lot of progress.

i finally borrowed another Philips drive from a friend and that worked fine. here is my hypothesis

  1. my sony drive is blown
  2. there are still entries in the registry that show entries for MYR3 and MYS6 version. (i flashed the upgrade as a part of my trouble shooting)

now i have removed all the CD/ DVD drives

any thoughts