Sony DVD RW DW-D56A Stops working randomly (flash problem?)

vbimport

#1

Hey, I have a problem with my Sony DVD RW DW-D56A on a Dell laptop, I wanted to burn DVD-R so I had to do a crassflash to a liteon PST3b flash. It worked great in the beginning without any problems, then one day I saw the DVD-ROM popped out. I closed it and tried to run a CD but it wouldnt recongnize anything. The dvd-rom was recognized in the system, but the dvdrom wasn’t spinning and I couldnt open it with the button. I reflashed it back to the original flash but it still didn’t work, so I re-reflashed back to the PST3b and it finally worked again. Later on in the months I ran into the same exact problem again, the dvd-rom popped open and I did the same method as before but it didn’t work. So I upgraded to the PFS3 original for sony but it still didnt work, so I tried omnipatcher and enabled cross-flashing on it, and it finally worked again. Then the same exact problem arised. I am tired of having this problem keep coming up and I don’t know what is the exact problem, can someone please help me? I can have it dvd-rom work for about a day before it fails on me again. I also realize that the dvd-rom pops out when the computer does an automatic suspend or hibernate, but whether it suspends or not the dvd will stop working in a day after I try fixing it.


#2

Hey an anyone please help me?


#3

I would contact Dell and complain about the burner, but keep my mouth shut about any firmware flashing…


#4

this is under the assumption that I have warranty… Can anyone please help me?? Can you guys please just spend the little time to try and help me out here?


#5

He [I]was[/I] trying to help. Remain calm, alright? At least you can get the drive to work temporarily. Reflash to the original firmware, then try calling Dell and claiming your drive is defective – see if they’re willing to do anything. It sounds like that may be what it is. The other thing you may want to try is getting Codeking’s EEPROM utility (http://codeguys.rpc1.org/utilities/EEPROM_Utility-3.3.3.rar) and clearing out learned media and hypertuning data, as this has fixed problems for me before.

Also check here:
ftp://ftp.vaio-link.com/PUB/Downloads/SO/F/OPD/SOFOPD-00829906-UN.exe
ftp://ftp.us.dell.com/rmsd/R104295.EXE
http://www.liteonit.com.tw/ODD/WebFW/SOSW-852SX/DR8PSX3.zip
for possibly more recent Sony/Dell/LiteON branded firmware, respectively.
You’ll have to crossflash most of these with FlashFix or similar, obviously.

Best of luck.

-silent


#6

thanks soo much silentcircuit… it works great now.


#7

which of these things worked for yoou? I have been having the same issues.