Sony DVD DW D56A burns very slowly

Hello everyone,

Recently I got a Sony VAIO notebook VGN-397XP with a dual dvd writter DW D56A. Everything seemed to be fine, until I tried to rip a dvd movie. The problem is that although the ripping ends successfully, the whole procedure takes a lot of time (1h 45mins approx.). Friends of mine with other dvd drives need approximately 35-45 minutes. I updated the firmware (with the latest driver that I downloaded from the sony website), and although during the first couple of times the ripping ended very fast, all the other times it takes a looooooooooooooot of time.

In addition, when i trie to burn cds/dvds with other data (ie mp3, photos, etc.), the burning process ends successfully and very fast.

Moreover, the shoftware that I use are DVDshrink, anyDVD, cloneDVD, nero6 ultra, but all of them need the same time to rip the DVD (clone dVD is a bit faster).

Something else that i noticed, is that with DVDschrink, i couldn’t rip dvd movies that were made by sony (dvdshrink crashed during the first step of analyzing the dvd); that’s why i turned to anyDVD+cloneDVD.

Please let me know what should i do, cause the long time is driving me crazy.

Regards,

George

most often the cause of long rip times is either the drive speed limit or DMA/UDMA not being enabled. to check for DMA.

Open Device Manager.

Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.

Right-click the icon for the channel to which the device is connected, select Properties, and then click the Advanced Settings tab.

In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is “PIO Only.”
If the drop-down box already shows “DMA if Available” but the current transfer mode is PIO, then the user must toggle the settings. That is:

• Change the selection from “DMA if available” to PIO only, and click OK.

• Then repeat the steps above to change the selection to DMA if Available.


next thing to do is get a decent firmware on the drive. codeguys have patched/patchable Sony DW-D56A firmwares @ http://codeguys.rpc1.org/firmwares.html

also you will most likely need more help. so go to the Lite-On/Sony forum and post your issues and read up and inform yourself
http://club.cdfreaks.com/forumdisplay.php?f=44

Thanx for your quick answer; however, how could i recognize to which controler the dvd is connected? In addition, I found out that there are 2 primary and 2 secondary controllers listed at the device manager (and of course some other things…)

use nero infotool. after it loads choose the configuration tab.

get it @ http://uploadhut.com/view.php/365320.rar

Thanx for your reply; I run the infotool and I see that the DMA is off. Moreover, I opend the device manager to change the settings (as you recommended), and although I changed the “transfer mode” from “PIO only” to “DMA if available”, I cannot change the “current transfer mode”, which is greyed to “PIO”… I also read your CD & DVD troubleshouting guide, and Microsoft’s remarks for the DMA and PIO conditions. The latter suggests that in order to make these changes (if some errors occur), is to uninstall the drive and install it back again. I also did that, but when windows found and installed the new hardware, the settings remained the same.

Any more ideas and/or suggestions?

Thanx in advance

OK, it seems that I managed to fix the problem. At the device manager, hardware, IDE… controllers, there were listed 2 primary IDE (1 for hdd and 1 for dvd) and 2 secondary IDE controllers.

Firstly, I tried to remove all of them and let windows find them and re-install them. However this did not fix the problem. Secondly, I removed only the 2nd primary IDE controller (dvd), and after I restarted windows, they re-installed the controller, with DMA enabled!!!

So, go to the device manager, try to remove the controller that has the DVD, and let windows detect it and re-install it. That may fix the problem.

PS. I noticed that the hdd is working at ultrdma5 and the dvd at ultradma 2. Is this normal?

Yes, those are normal speeds.