Sony DRU710a Problems?

vbimport

#1

I hope someone can give me some suggestions on what is wrong. I bought a new DRU710 to replace my faithful (but aging) DRU500a. Really I have only used the new drive in earnest for about 2months, and it has been an exercise in frustration to say the least.

From day 1 it has been incredibly picky about media. For the most part, I use Verbatim and Memorex, and they work pretty well. I sometimes burn discs for friends, and they prefer cheaper media - some works, some doesn’t. A bit disappointing for a new drive, but I tell them get better discs…

Well, most of my Memorex burns are data backup. Burn completes successfully, but I recently had to access one of the discs to restore some data, and it was corrupt (despite Nero giving me a burn complete message). Check the other archived discs, and ALL have corruption. Ran them through CDCheck, and multiple CRC errors.

Interestingly, I installed an old Toshiba DVDROM, and all discs read, and pass CDCheck. I suppose the Toshiba has a higher error tolerance than the Sony, but again, this is disappointing for a brand new drive.

Decided to play around and burned some movie discs - similar results. Play fine on my stand alone Pioneer DVDrecorder, but not on my RCA player. I assume again that this reflects error tolerance.

Final straw came this week when trying to install new Palm software, and the Sony drive couldn’t read the disc (pressed, supplied with the new Palm). Installed fine from the Toshiba.

Thinking this is unacceptable I contacted Sony tech support. They say upgrade to BYX3 firmware (not sure how that would improve the DVDROM function of the drive, but I try anyway). Well, now I can’t even burn DVD- media period. + seems to work, but the quality is not improved.

I tried to burn a DVD-RW (Verbatim) and DiscJuggler gives me an “Illegal mode for this track or invalid packet size” error. It claims the disc is empty. When I try using Nero, it tells me the disc isn’t empty, and it tries to erase it, but never does. DiscJuggler gives an SRB error.

I have formatted the hard drives, uninstalled all burn software and just reinstalled DiscJuggler, updated the aspi layers and no success.

I would be hesitant to try hacked firmware, as I am still holding out hope that Sony might replace the drive (yes, I have been told that I am delusional…).

Anyone have any ideas???


#2

hey, nice first post!

you can try a liteon firmware: http://codeguys.rpc1.org/firmwares.html#SOHW-1653S
if this doesn’t help, flash back to 710A and ask the store for a replacement.

Edit: updating to BYX4 is probably a better idea… --C64K


#3

Don’t think the store will likely replace it(BestBuy). It is almost 3months old now. If Sony won’t do anything (which I doubt they will), then it will be a nice ornament I guess.

Will look into the LiteOn firmware (although I can’t think any firmware will correct the read problems with the drive).

Great forum BTW :slight_smile:


#4

make sure DMA is enabled in BIOS and in windows. you can also try to remove the drive from device manager and reboot the pc. it may help.


#5

Yes, DMA is enabled (on both primary and secondary IDE). I did try an uninstall, but it never actually uninstalled the drive (was still there on reboot)

It seems that the 1x Verbatim DVD-rw are the main problem (but they are what I always use for converting TV shows etc, cause I watch and erase, reuse). I have about 10, and they all worked, but now I get that illegal mode error. Could the firmware have removed the support for these discs?

Is there any way to go back to BYX2 or BY02, without using the hacked firmware? And if I upgrade to the firmware you mentionned, can I go back to 1 of the previous versions if it doesn’t work?

Thanks :slight_smile:


#6

you must have crossflashing enabled in the stock firmware flasher to downgrade the firmware. there only shouldn’t be any other modifications done to the firmware!


#7

Sorry, dumb question - how do I enable crossflashing exactly? (do I just run through the omnipatcher first?)

Oh, and do I really have to disable DMA before flashing, or is that overkill?


#8

to enable crossflashing, just load the firmware into omnipatcher and tick the box (ignore the media table error message). save the firmware and apply it.

and do not turn DMA off.


#9

Ok, I successfully upgraded to CS0K firmware (with Sony ID). Successfully erased 1 of the Verbatim DVD-RW, but now I am getting the “invalid parameter set in SRB” error again, followed by “session fixation error”. Still can’t burn to the disc, even the one that erases sucessfully.

Any other options?


#10

you can only wait for a real professional to answer.


#11

LOL - You’re help has been much appreciated.

Personally, I think the drive has been crap from day 1, but who knows.

Interestingly, I have gone back to BY02 firmware, which did work fine, and I am still having the same problem.

However, I have played around with the burner a bit more, and currently it is writing some data to one of the DVD-RW discs. Now I was trying to burn an iso, which I have burned on many occasions before, but I wonder if perhaps the problem is the new version of DiscJuggler, not my burner (boy, I would feel pretty stupid if that was it).

Can’t see any reason why DiscJuggler would successfully burn data to a DVD-RW, but not a stored iso, if the problem was the burner itself.

I may try uninstalling DiscJuggler, install Nero only and try to burn the iso with it.

Will post back…


#12

Hmm… Your experience has many similarities to my experience with my DWD-22A aka DRU710A. I’ve had mine for a few months and now it won’t even recognize most media. Reflashed and other steps but no joy. I am beginning to wonder about the quality of these drives or at least how well they we debugged before sold to the public.


#13

I downgraded the firmware on my Sony DRU710a from BYX4 to BY02 using ftp://ftp.vaio-link.com/pub/DVD-Link/Downloads/710a_by02.exe withought making any additional modification to the default settings of the firmware.
The only prep was to follow the sony instructions: “When using Windows 2000 or Windows XP, log on to Windows as the computer administrator or as a user with administrator access privileges.
Before executing firmware update, uninstall any packet writing software, such as [DLA], [DirectCD], [B’s CLiP] etc, from the PC.
If you are using the DRU-710A, disable [DMA setting] in Windows before executing firmware update.”


#14

have you tried erasing/formatting the DVD-RWs in a different burner? I used to have the same problem with Verbatim low speed(1-2x) DVD-RWs and my 812S.

Also have you tried DVD Decrypter? Go here for it DVD Decrypter Download . It’s FREEWARE and works great. Have used it now for almost 2 years and the only error I ever get is when my CRAP media fails burning.


#15

diskdocx,

Welcome to the Sony “you thought the drives were bad, wait until you call tech support” club. I wouldn’t even bother calling them. They sounded like their last job was ‘would you like fries with that?’ and they got fired because that was too complex for them.

Regardless, I’m stuck with one of these drives, as well. The newest BYX4 firmware with codeking’s modifications–to make the LED behave in a sane fashon–work well. The main media I burn is a very cheap 8x media. I have found the same media ID on five brands of discs! laugh It’s everywhere! The trick is that it burns wonderfully at 4x, but horribly at 6x or 8x. So, I used the firmware patcher to force the drive to only burn at 4x–several programs I use have poor media speed selection.

The media in question is CMC MAG E01. I’ve also had luck with a DVD-R media FUJIFILM03 which works fine at 8x.

A while back I had good luck with 16x verbatim +R media, but at the price, I didn’t burn much of it. I’m rarely that pressed for time. :slight_smile: 8x is as fast as I ever need to go. That having been said, 4x is a little beyond my patience, but I have 100 discs to burn and they only work at 4x, so…

Best of luck with you drive and welcome to the forums. PM me if you think I can be of further help–assuming this was of any help… :slight_smile:


#16

Hve you tried strategy swapping?
CMC MAG E01@MCC003 :smiley:
CMC MAG E01@CMC MAG M01???

http://club.cdfreaks.com/showpost.php?p=983836&postcount=239
http://club.cdfreaks.com/showpost.php?p=984022&postcount=241
http://club.cdfreaks.com/showpost.php?p=984033&postcount=242
http://club.cdfreaks.com/showpost.php?p=987063&postcount=243

The brand of these CMC MAG E01s is TDK (50pk spindle). One is non-printable (blue top) and the other is inkjet printable.

Hope this helps your dilemma


#17

ouch! my first drive was a DRU500a and I hated that, it was incredibly fussy about media as well. I quickly moved onto pioneers once prices started dropping. But I guess you’ll probably stick it out until it really pi$$es you off then go get something else. If you look around the forum most people dont like sony burners (liteon burners) except for scanning disks for quality, and seeing your burner is such a bad reader it wouldnt be much use for that. Good luck, anyway, sorry to not be of more help


#18

I too have a Sony Dru710a and yes I agree there are a few problems associated with the device. I have burned 450 DVD’s before the drive actually died. You should try using “Laser” brand blank DVD’s. They are generally cheaper and work just as well. (These may be purchased at outlets such as Strathfield car radio, CX Computer stores or Parklea markets. Avoid going to Myers as they overprice all computer products). Out of 420 blank 8X “Laser” brand blanks I can honestly say I have had 0 duds. After awhile the burner will start to burn dvd’s that will freeze in your dvd player. This is not a problem with the blank dvd but with the burner itself. Hopefully, this should happen prior to your warranty period finalising (You’ll be replaced with a new burner cause even the computer shop owners know that Sony is crap - when it comes to burners) Sony does not make their own burners. They are made in China and come complete with bonus reject Lite-on drivers. If you want quality you should try Pioneer (currently ranked number 1) which you can purchase for $66 or Lite-on (ranked number 2 - with decent drivers).

Also, when burning try to avoid using your PC as this may affect the buffering. Programs such as Adobe photoshop seem to do the most damage when burning.

Best of Luck

Stirfry


#19

you guy have been so helpful! I also have a 710 and am have problems burning i was told by a chum that my drive sucks as well as my sony(AML dvd media ) sucks, I unknowingly upgraded my firmware to byx4 and now i cant write at 16x. In addition i also have a Iomega dvdrw4224. Is this a “good” burner drive(compared to my 710? I just ran a diagnostic and sent the packet to cust support! After reading your posts i feel a little discouraged! so all your comments will be greatly apprecated!


#20

i crossflashed my dru710a to 1653s CS0P. with the right media (mcc, rjpn, ty) it’s a very good drive. i saved it a lot of times during neverending lead-out by imediately turning off my pc, the drive’s still ok.

the Iomega dvdrw4224 is a LG GMA-4040B OEM.
just look in the LG forum: http://club.cdfreaks.com/forumdisplay.php?f=91