Sony DRU510A new 1.0c firmware

sony.storagesupport.com/dvdrw/dru510adwn.htm

Has anyone gotten this firmware update to work? After following all instructions, when I execute the 510A_10c.exe file, my system reboots.

Thanks for any info.

Same here :frowning:
that’s very strange. Anyone who got any luck flashing it?

I finally figured out what the problem was. I have a PNY flash card reader that adds two drive letters so that I can access flash media. When I unplugged the reader, the firmware updater worked just fine.

system: winxp sp1
drive: DRU-510a 1.0b

My drive updated fine. What i did…

  1. set my drive in pio mode by using divice mngr.
  2. closed all running programs
  3. started the update file
  4. rebooted when asked
  5. comp. restarted into the updating program
  6. rebooted
  7. drive sucessfully updated to 1.0c

Checked with discinfo and nero burning rom.

Got it to work as well finally! But haven’t found a changelog, do anyone know what has changed…

If anyone has some Princo 4X… give it a go and let us know. The 510 wouldn’t burn it @ 4X, only 2X.

I burned one yesterday – Princo DVD -R) – burned @ 4x, plays in both players we have here (2yo Wintel WIN9663x and almost new Sharp DV-NC70X DVD/VCR combo.)

Same title burned to Verbatim DVD-RW (tried both DVD + & - RW) will only play in the Sharp, the Wintel bombs on it.

Title - Disney’s Fantasia 2000 - the only protected DVD I have in the house, hence it gets experimented with.

Made the copy with Clone-DVD direct from the original disc.

Before you say “that’s impossible”, try this: Insert a copy made with DVD-Decrypter (one of the DVD-RW’s I’ve been playing with) in the reader.

Start Clone-DVD & wait until the disc is recognised, but stay on the first screen.

Remove the disc and replace with the protected one.

Complete the Clone-DVD routine.

Probably worked because I didn’t really need the copy anyway:D

It’s a movie you’d only watch once.

PS: Installed the 1.0c firmware – no problems.

Did anyone try this on the DRU500a ? If its even possible…?

my 500a drive had 2.0f and it will only write 4x in test mode (nero and dvddecrypter) - and i’m sick of it! :\

/me

Ever since ruining a LiteOn burner from a bad firmware flash i’ve been really nervous flashing drives, especially my brand new DRU510a. Can someone tell me exactly what steps I need to take to not mess anything up. Does it matter what channel the drive is on, or whether it’s master or slave? Should I turn PIO mode on instead of DMA? Anything else…?

There’s a very good ‘guide’ right on their homepage that tells you everything:

http://sony.storagesupport.com/dvdrw/downloads/Firmware10c/510update.htm

neat, ey?

Following that works for me.

/me

kick ass, updated successfully. thanks :slight_smile:

I just bought the Sony DWU-14A, which is the oem of the 510A. Does anyone know if the firmware 1.0c for the 510A is OK to use on my drive?
I’ve used Nero 6.0.0.9 and tried to burn a DVD-R on 4x rated media, but the Nero drop down box only gives the option to burn at 1x. I don’t know if this is a problem with Nero, my firmware (1.0b) or defective drive. I can burn 2.4x DVD+RW media at 2.4x without any problems.
I tried the Sony DriveCheck program, but my drive failed, no information as why it failed. I find this somewhat suspect, since I can burn to both DVD-R and DVD+RW, just a problem with speed.
Any suggestions?

I was also curious if anyone has used the Sony 510A or 14A with 4x rated DVD+RW media, or if that type media is even available yet?

I think it’s available in some areas – haven’t seen any in Australia as yet.:wink:

Does this firmware update work for the OEM drive (DWU-14A)??? I’ve been having no luck with it since I bought it last week. It could be my media I suppose…

System| XP Pro (running on)-

Asus A7m266-D
Dual Athlon MP 1900
ATI AIW 8500 DV
5 100 Gb WD1000JB
via Promise SuperTrak 6
IGb DDR
Antec 400 Watt

+Plextor 40/12/40A

So long as it is the OEM version (off the same production line in the same factory), there’s no reason it shouldn’t – the hardware/firmware would be the same.

However, I’ve never seen one and Sony don’t volunteer information.:frowning:

The 1.0c update for the retail version made quite a difference to its appetite for media – not nearly so picky.:slight_smile:

I found the OEM firmware (1.0d) - flashed - and it works on all media I’ve tried so far. Of course, that’s just fuji and verbatim. Great site for firmware:
–forum.rpc1.org–

Someone test nashua and princo as media ?? and imation ?

Well I went there and tried to find it… unless its been removed… all I can find are alot of other people asking the same question…
where is the 1.0d firmware for the dwu-14A?

If you can find it again and link us to it… that would be just dandy!..:stuck_out_tongue:

-Hope this isn’t too late for you!

http://forum.rpc1.org/dl_firmware.php?download_id=1618