Sony DRU-810A locked at 1x after working fine for weeks. What now?

vbimport

#1

I have a pretty powerful system made up of a Gigabyte GA-EP45-UD3R, Intel Q9550 Core2 Quad, 4GB Corsair Dominator RAM, a 750W Corsair PSU and a Sapphire Radeon 4870 running XP ProSP3. It’s running pretty fast still after two years. I also have a Plextor PX-708A and a Sony DRU-810A for reading and writing.

I decided to backup my DVD collection to ISO images for use on a new Mvix 880 media player and several 2TB drives. I got through about 260 of them, all being ripped at 4x resulting in 20min rip times, before I got to one that gave me enough trouble such that I could not back it up. Likely newer encryption the software I use can’t handle. No big deal but I did try several software solutions all of which caused the Sony to churn excessively as it tried to cope with the disc. Unfortunately, the disc could not be backed up.

Sadly, after moving on to the next one, I found the drive suddenly appears locked at 1X no matter what I do. I’ve run several diagnostics against it including Nero tools as well as adjusted the settings of the ripping software to rip at maximum speeds but to no avail. I’ve even gone so far as to re-flash the firmware on the drive to see if that would help but the thing appears to read ONLY at 1x. All the diagnostics I’ve run say the drive is capable of reading at speed and tests OK.

Not only that but I attempted to write a data backup of 6GB to a DL disc and Nero said it was writing at 4x but it ended up writing for over an hour! Clearly a problem as that should have been written much quicker.

So, any thoughts? I’ve tried all the usual tricks and checked my system but the drive appears to have toasted itself after that one DVD. The Plextor appears to read and write just fine but it’s not a DL writing drive.

I did not think the “simple” task of trying to read a protected disc would actually break a drive. It can play the movie back using PowerDVD just fine so the drive clearly works, just only at 1x.

I’m thinking it’s just time to replace it. If anyone has some thoughts, please let me know.

Thanks,

Kevin


#2

It is very frequent that after trying to rip a problematic disc, the computer automatically (and without any warning for the user) revert the IDE channel mode to PIO.

Reverting to DMA should solve :slight_smile:


#3

Thanks geno888. Unfortunately, that was one of the first things I checked. It’s still enabled for both drives and I’ve actually gone so far as to disable it and re-enable it but it’s still reported that the Sony is under DMA mode as it should. That was confirmed, I believe in Nero Info Tool. I can check it again though.

If there’s some esoteric location where it’s being overridden, I guess I can look for that or, at worst, uninstall the IDE controller and reboot. Windows should reinstall it when it starts up again and I can check to see if it’s working right. Maybe update the driver to a newer version but I’m fully up to date as far as I know.

I’ll check it again anyway.

Thanks,

Kevin


#4

[QUOTE=kevinkar;2572820]…or, at worst, uninstall the IDE controller and reboot. Windows should reinstall it when it starts up again and I can check to see if it’s working right. [/QUOTE]

This usually helps, give it a try. :wink:


#5

Will do!


#6

[QUOTE=kevinkar;2572820] It’s still enabled for both drives and I’ve actually gone so far as to disable it and re-enable it but it’s still reported that the Sony is under DMA mode as it should. That was confirmed, I believe in Nero Info Tool. I can check it again though.[/quote]You might please check the “current transfer mode”. This is a more valuable information than the presence of the “DMA if available” checkmark.

Michael


#7

Thanks for the input Michael. I did indeed check that out and everything was set to what it should be. I’ll note I have SATA hard drives and the two DVD drives are the only IDE drives. Both were shown as “DMA if available” and both were showing DMA (can’t recall the number showing but it was correct when I checked.)

I did uninstall/reboot/re-detect the IDE controller and ran through all the common items again and as before, everything was indeed set properly. I then ran through Nero DiscSpeed again and tested both drives, writing and testing data discs for both CD and DVD and the results were all “normal”. (The media used showed some high levels of errors but I was not concerned with errors at the moment, just read/write speed) and both drives peaked at their maximum values (8x for the Plextor and 18 for the Sony) which implies they are working correctly.

Since I did this late last night, I did not test ripping a random DVD but will do that later on tonight. IF it again fails to read at greater than 1X, then I’ll have to see what’s up with the software. Perhaps the defaults got corrupted and I need to delete it all and reinstall (just the standard tools like DVDdecrypter and Alcohol120). The Nero results indicate it should be working properly though. That’s promising.

One more thing - I got my numbers mixed in my head/subject. I have a DRU-840A, not an 810. Not that it makes that much difference because both models read at higher than 1X anyway.

Thanks again for the suggestions.

Kevin


#8

Everyone,

Thanks for the suggestions. Apparently only one worked but it is still odd how/why. The only thing that got the drive to start reading (and writing, I guess) at speed was to uninstall the IDE controller and have Windows re-recognize it and re-install the drivers. Tried a couple of remaining DVDs and they both were ripped into ISO images in a “normal” time of 20min (roughly a 2x-5x speed being reported through the rip).

Now, before uninstalling the controller, I went through and wrote down all the settings for everything about it that I could find which included any utility output or log output as well as the settings for the drive and controller from Windows’ Device Manager and compared them all to the same settings after the re-install. As you would expect, all of them were the same. Not one setting was different yet the read speed of the drive went from 1x to 5x. Ugh.

Of course the drive doesn’t seem to read any faster than that although it should have a DVD max read speed in the 12x-16x range. Maybe it’s riplocked and I never knew it.

Anyway, it magically started working again after the re-detection and installation.

Thanks again,

Kevin


#9

Can you run a burst rate test with cd-dvd speed or with optidrive control and post results here?


#10

I can…

That’s with the newly generated test disc made moments ago. Doesn’t indicate a problem that I can see. The disc quality was a different story but this might not be “quality” media (Sony DVD-R). Every CD and DVD I’ve made have all been fully readable to this point save for a few early samples with other drives.

Note I am using the OOTB SS00 firmware. Never had a need to flash it though it’s possible the later patched SS01 might increase the read speed. Not overly concerned with write speed though I have been scanning hundreds of family negatives and giving copies to my brother, sister, etc. Those DL discs could be written a bit faster maybe but they’ve been writing fairly quickly such that I have not noticed a real problem with them. Only recently when the drive locked at 1X.

Am I missing something?

Kevin



#11

Based on the burst rate the drive seems work correctly.

Maybe lock is in the firmware so when you try to rip a disc there is a slowing.

I wonder if with MCSE you can unlock firmware.


#12

C0deking did some magic on this recycled TSST drive:


:slight_smile:

Michael



#13

Michael,

I did indeed see C0deking’s firmware and had already grabbed it but just hadn’t gotten around to flashing the drive. Did that before I logged back in to see your note suggesting it. Updating to patched SS01 did change it ever so slightly. It now averages slightly higher in read speed but gets up to 18x instead of just 16x and the burst rate is ever so slightly higher. You can see the graph shows it running a bit faster though there are way more drops through the burning of the second test disc than the first disc I burned with SS00. Odd but probably not a real problem. Access times were a bit slower. Disc quality graphs were better too.

However, regardless of what Opti Drive shows, I ran a previously ripped DVD through and it ripped it in FIVE MINUTES instead of twenty! The read speed jumped from about 4x-5x up to 11x-12x. Clearly the drive was riplocked or had some other issue which was fixed with the SS01 patched firmware.

Imagine realizing this after archiving 275 ISO images, all at about 20 minutes each (91 hours) being cut down to 23 hours! :doh:

So, lessons learned: remove/reinstall the IDE controller as a possible solution and patch the firmware wherever possible BEFORE you take on a DVD archiving project.

Thanks again for the help, suggestions, etc. Now I won’t have to buy a new drive for a while longer.

Kevin