Sony DRU-800A KY01 F/W

vbimport

#21

Here’s a RITEKG05



#22

Here’s the Nero Disc Quality Test for RITEKG05 for the burn above



#23

KY01 is better than KS04 ? :stuck_out_tongue:


#24

C0deKing, perhaps this should be moved to the “Changing stratergies” thread, so everyone can see.

@besmirch

KY01 is better than KS04 ? :stuck_out_tongue:

Need to do a bit more testing like strat swap, so I can compoare results with what I have already burnt on 1673S/1693S


#25

Sorry, I don’t see the strategy change :confused:. This is the best place at the moment to show the results of KY01 ;). Looks good so far :).


#26

2nd RITEKG05




#27

Ritekg05@ttg02




#28

@C0deKing
http://club.cdfreaks.com/showthread.php?t=136158

CORRECTION! Bitsetting appears to be broken in BYX4. It supports the set and get bitsetting functions but the bitsetting does not take place during the burn. This has to be a mistake, as these functions are usually removed as well if they don’t want the firmware to be able to bitset.

C0deKing, I can also confirm that DRU-800A also has NO AUTO BITSETIING, even with Omnipatcher option enabled!!! Dumped KY01 firmware to confirm and “Enable auto-bitsetting” is ticked!!. No reboot is needed, as soon as drive tray is opened, BITSETTING is RESET.

Also,
@C0deKing
http://club.cdfreaks.com/showthread.php?t=136158
Originally Posted by bichonn
Have got an idea why my ide light was blinking with my drive light with this FW? I am not talking about the dead drive blinking light !!! The drive was fworking fine but when burning or reading, the ide light was blinking with the drive light.

Sony firmware has additional code in the LED routine that sets the IDE pin for the LED. I don’t know why and I don’t know why only the Sony firmware has it but it is quite normal.

This only occurs during Lead-In & Out and also tray open/close, not actually during the burn.


#29

Here’s a RITEKR03-02.




#30

It does clears it when the disc is ejected. I wonder why they did that. I’ve removed it ;).

In the Sony firmware the IDE led will mimic the drive light. If the firmware is ledfixed then this is removed during reading and burning ;).

@all
FYI, instant bitsetting of +RW still works with this firmware and the v1.35 Liteon booktype utility. So far my inital attempts at getting bitsetting to work have not worked :sad:. Don’t know if I should spend much more time on it…


#31

Fixed it! :slight_smile: I had overlooked the obvious. It was easier than I thought ;).

I’ve tested it in my 1653S with BYX4, any testers for KY01?


#32

DEFINITELY, please C0deKing.


#33

Also C0deKing, perhaps a KY01 for 1673S or 1693s?


#34

Do you mean a crossflashed Liteon ID version?


#35

Do you mean a crossflashed Liteon ID version?

Yes, please. I’d really appreciate it. Also can confirm that SafeDisc v2.9 (Sim City 4 Deluxe) can be copied without “Bypass EFM errors” ticked in Alcohol 120% with 1673S@KS04. Only emulation ticked is “Ignore Media Type”. Read in 1673S, SOHD-167T (No emulation) & SOHR-5238S(also with "Ignore Media Type " ticked) to play. Am now testing SafeDisc v3.20.020 (The Sims 2).


#36

Thanks “The Black Wizard”.

I’ve decided to release a patch tool for the bitsetting fix. You’ll find it here:
http://club.cdfreaks.com/showthread.php?t=137225

I’ll release the Liteon ID version of KY01 soon :slight_smile:


#37

I’ll release the Liteon ID version of KY01 soon

Big thanks :cool:


#38

SafeDisc v3.20.020 COPIED.

Program - Alcohol 120% v1.9.5 Build 2802
Profile - Safedisc 2/3
Bypass EFM Errors - UNCHECKED
Title - The Sims 2
Burner - Lite-On SOHW-1673S cross-flashed to 1693S
Firmware - KS04 (Thanks C0deKing)
Media - TDK 650MB 4-10x High Speed CR-RW
Burn Speed - 4x
Media - Verbatim 700MB 1-52x Inkjet Printable CD-R
Burn Speed - 8x
Reader - Lite-On SOHW-1673S cross-flashed to 1693S
Firmware - KS04 (Thanks C0deKing)
Read Success - TDK - Yes; Verbatim - Yes
Reader - Lite-On SOHD-167T
Firmware - 9S19 (Thanks C0deKing)
Read Success - TDK - No; Verbatim - Yes
Reader - Lite-On SOHR-5238S
Firmware - 4S05
Read Success - TDK - No; Verbatim - No


#39

A version of KY01 in now posted with crossflash, bitset fix and optional Liteon ID:
http://codeguys.rpc1.org/firmwares.html#DRU-800A


#40

Thanks C0deKing :bow: :bow: :bow: