Sony DRU-720A problem, please help!

vbimport

#1

I bought this dvdrw drive couple days ago and try to install it today, and it doesn’t work. My computer using AMD Athlon XP, 2.16GHz, 512 MB of ram, window xp pro. Writing software is Nero.

The problem is that, the drive won’t read any cd or dvd. It’s detected on the [my computer] thought, but when i put cd in it, it did not read at all. The device manager also said that it’s working properly.

I don’t know if it’s because of defect part or not, I’ve look at the Microsoft website, and look at the Hardware Compatability List, and this drive wasn’t on the list.

I’m so frustrated because I paid extra money for the drive, just to get Sony because of brand name reputation, but it seem that I’m wasting my money.

Can anyone please help


#2

Welcome to cdfreaks :slight_smile:

The 720A should work fine in your system. See if this helps. Using device manager, delete the IDE channel that the drive is connected to and then reboot your system.

If this doesn’t help, use Nero Infotool to generate a report of your system (with all options checked) and attach this to a post as a text file.


#3

Thanks C0deKing,

I try to delete IDA and reboot, but it still does not work

Nero InfoTool 3.00

Drive Information
------------------
Drive                      : SONY     DVD RW DRU-720A 
Type                       : DVD±R/RW DL Recorder
Firmware Version           : JY01
Buffer Size                : 2 MB
Date                       : ?
Serial Number
Vendor Specific            :   Dec28 ,2004        
Drive Letter               : E:\
Location                   : 1:1
Mechanism                  : Tray
Read Speed                 : 48  X
Write Speed                : 48  X

Read CD Text               : Yes
Return C2 Pointers         : Yes
Read CD-R                  : Yes
Read CD-RW                 : Yes
Read DVD-ROM               : Yes
Read DVD-RAM               : No
Read DVD-R                 : Yes
Read DVD-RW                : Yes
Read DVD+R                 : Yes
Read DVD+RW                : Yes
Read DVD+R DL              : Yes
Read BD-ROM                : No
Read BD-R                  : No
Read BD-RE                 : No
Read Digital Audio         : Yes
Read CD+G                  : Yes
Read VideoCD               : Yes

Write CD-R                 : Yes
Write CD-RW                : Yes
Write DVD-R                : Yes
Write DVD-RW               : Yes
Write DVD-R DL             : No
Write DVD+R                : Yes
Write DVD+RW               : Yes
Write DVD+R DL             : Yes
Write DVD-RAM              : No
Write BD-R                 : No
Write BD-RE                : No
Buffer Underrun Protection : Yes
Mount Rainier              : No
Modes                      : Packet, TAO, DAO, SAO, RAW SAO, 

RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control  : RPC II
Region                     : None
Changes User               : 5
Changes Vendor             : 4


Interface Information
---------------------
Adapter 2
---------
Description           : Secondary IDE Channel

Driver
Description           : System32\DRIVERS\atapi.sys
Company               : Microsoft Corporation
Version               : 5.1.2600.2180 (xpsp_sp2_rtm.040803-

2158)
Description           : IDE/ATAPI Port Driver

Attached Devices
Description           : Master: SAMSUNG CD-R/RW SW-252S
Type                  : CD-Rom Drive
DMA                   : On
Autorun               : On
Description           : Slave: SONY DVD RW DRU-720A
Type                  : CD-Rom Drive
DMA                   : Off
Autorun               : On

I notice that the DMA for it is off, is that a problem?


#4

DMA off is really a big problem.
You need at least UDMA 2 or 3.
Check youe Windows Porblem.


#5

Also make sure DMA is enabled in the BIOS. :wink:


#6

Thanks for the replys. I’ve already enable the DMA, but the problem is still remained. Current transfer mode: UDMA 2. Could this be problem with the laser?


#7

No offence but are you sure you deleted the “Secondary IDE Channel” in device manager?

Enable all of the report options in Nero Infotool and post the new result…


#8

Very interesting!

I have the same problem:
Under WinServer 2003 i tried to install the Sony DRU-720a as a backup solution.

The funny thing: It is recognized by Windows, Nero BackItUp works fine with it, but you cannot read the data out - nor you can read any other DVD´s/CD´s. Restoring the data by another DVD drive works fine, too.
I put the drive as master, slave and cable select, with and without the second DVD drive. DMA is on (DMA4) so this cannot be the problem as well.
The first thought i had was that the drive doesn´t like windows server 2003, but it seems to be a little more complicate.

If someone has a good answer to this behavior (burning, but not reading media ?! :confused: ?!), please tell me…

Best regards, UncleFox


#9

I had the same problem under XP, swapped a plain CD player with a new 720a… burnt a couple fine then started giving me the “illegal disc” error. (using dvd43 with dvd shrink…)

Updated firmware… no luck…
Got some sony-supported verbatim discs… no luck…
Updated Nero… Still no luck…

However Musicmatch Jukebox was giving me problems and would not read from the drive… then no programs could read from the drive.

Have since uninstalled Musicmatch, Nero and DVD Shrink… Reinstalled Nero and Shrink and hey presto the drive burns fine at a full 8x on DVD-R and all other programs now read the cd’s etc…

Worked for me?!!


#10

@ Ramzee
Welcome:). Thanks for posting your solution as it may help others.


#11

hello. i have a similar problem. i also purchased the sony dru-720a and have trouble reading/installing media. even the sony software disc that came with the unit took a few tries before working. but i notice i can burn software without a problem. i tried to check if it was the media but there was no scratches. it actually works on my other computer. when installing from the cd it sometimes has trouble reading. it sometimes goes 50% or 75% then gives me read errors. double checked the cables, the firmware is updated, checked the bios, tried everything posted above without any luck. could it be just a simple setting? thanks in advance.


#12

What burning software do you have installed?
Have you considered crossflashing to a Lite-On SOHW-1673S vJS07
Latest firmware for 720A is JY03


#13

hello. im sorry i’m not familiar on what crossflashing is.

by the way i’m using the nero software provided by sony’s disc.

thank you


#14

Open Nero Startsmart. Click The “flame” in bottom right corner. What version do you have installed? Also is Nero InCD also installed? If so REMOVE IT.


#15

just removed incd. im running nero 6. thanks


#16

just tried installing some games and some software and they all fail at 5-10 % during installation.

they are original software. =\

should i return this sony burner?


#17

indeed it was defective. thanks for all the help guys. appreciate it very much.