Sony DRU-500A doesn't blank DVD-RW anymore

hello there,
About 1 month ago I bought this DVD Burner, which worked perfectly until yesterday, when I tried to erase a full DVD-RW.
I cannot understand this issue, because the last time I used the same DVD-RW media it worked perfectly: I could write and rewrite 4-5 times a day.
Now I see it stopped working: I can burn on these media, but I can’t erase them anymore.

I have firmware 2.0g and already tried setting the 2.0c and 2.0f.

Can anybody help me please?

thanks alot

Pibe

What media are you using?

Originally posted by jsl
What media are you using?

I’m using “DATASAFE MEDIA” DVD-RW disks.

Actually if I try to erase them with Alcohol120% it says “cannot write medium. Incompatible format”, but I can sware that almost 2 weeks ago I erased those media! It’s a mystery for me…

hope you can help me

Try different software to erase the disk. I had similar problems with some RW disk in the past too.

could you suggest me some other software that could do the job? I tried Nero5, Nero6 and Alcohol 120%.
Some other software supporting DVDs…?

thank a lot

Pibe

Try Stomp or Sonic RecordNow products.

Also DVD Decrypter can erase disk and its free.
http://www.dvddecrypter.com/download.asp