Sony DDU1615 with GYS1 Firmware?

vbimport

#1

I recently bought a Sony DDU1615 DVD-ROM, and trying to update the firmware from rpc1org, and i get the error message “Sony DDU1615 not detected”. The current firmware the drive shipped with was GYS1 and the drive shows as a DDU1615, which as far as i can gather GYS1 is a Sony DDU1611 firmware. Can anyone else confirm this and find out how i go about flashing this drive so the rip lock for DVD-R meida can be removed as it is 8x and i want it to be able to read at 16x. The drive is also set to primary slave, if that helps at all


#2

Anyone ?


#3

Try crossflashing with this LiteON firmware - FS0D. Since Sony drives are really just rebadged LiteONs anymore, and LiteON tends to keep the firmware more up to date, crossflashing tends to be a good idea.

Step 1:
[B]Get all this stuff.[/B]
Grab the LiteON/Sony Windows firmware tool from here:
http://upload.cdfreaks.com/ftools/LtnFW.zip
Grab the EEPROM backup tool from here:
http://codeguys.rpc1.org/utilities/...ility-3.3.3.rar
Get the LiteON firmware (version FS0D) we’re crossflashing to from here:
http://www.liteonit.com/DOWNLOADS/ODD/SOHD-16P9S/firmware/P9SFS0D.zip
Grab FlashFix 1.1.1.12 and UPX.exe from here:
http://digi.rpc1.org/flashfix.htm

Step 2:
[B]Back everything up.[/B]
Run EEPROM tool, back up your EEPROM.
Run LiteON Windows Firmware tool, backup your firmware.

Step 3:
[B]Mod the new firmware so it’ll flash your drive[/B]
Unarchive FlashFix somewhere and put UPX.exe in the same directory.
Copy FS0D.exe (the LiteON flasher from the archive) to the same directory.
Run FlashFix, drag FS0D.exe in to the FlashFix window, it should say “file patched.” and create a FSOD.exe.BAK file – a copy of the unmodified flasher, “just in case”.
Close FlashFix.

Step 4:
[B]Crossflash the drive.[/B]
Close everything else, make sure there is no disc in the drive, don’t do this when the power is flickering, in a thunderstorm, etc., and run the newly modified LiteON flasher, FS0D.exe. Choose the DDU1615 ([B]make sure it’s the right drive, cause this modded flasher will flash any drive now[/B]) in the pull-down and click update. Wait. It should say “update complete” or similar and you need to restart.
[I]Do so. Twice.[/I]

Step 5:
Clearing some now maybe-invalid EEPROM data.
Run EEPROM utility again, but this time click “Reset Learnt Media” and “Reset HyperTuning”. If it gives you errors don’t worry – I’m not completely sure this step is necessary with a non RW drive, but I’m including it anyway.

[B]That’s it.[/B]
You should now, theoretically, be golden.

[B]In the event that something unforseen or otherwise really really bad happens:[/B]

  1. Stop panicing.
  2. Run the LiteON/Sony Firmware tool and restore the firmware backup you made.
  3. Failing that, get this flasher ftp://ftp.us.dell.com/rmsd/R113812.EXE and use the FlashFix app, then reflash the drive so it shows up as a Sony again, and you should at least be back to where you are at present.

Best of luck. It sounds scarrier than it is. :wink:

-silence


#4

Also, since you’re trying to remove the rip lock… that firmware may do it, but if it doesn’t you can use OmniPatcher – http://codeguys.rpc1.org/patchers/omnipatcher-2.4.4.rar – to patch the read speeds on the firmware, possibly.

To check: [B]after[/B] crossflashing back up the firmware on the drive with LiteON/Sony Firmware utility, then load/open this new backup in OmniPatcher and search through there for the read speed settings. Change them to whatever you want and save a new .bin with the new settings included. Open up LiteON/Sony Firmware utility again and load this patched firmware, then update the drive with it. Restart and check read speeds, and they should be whatever you selected.


#5

Thanks for all the silentcircuit. I’ll try all that and post the outcome.

Cheers

John


#6

I followed all the steps and crossflashed the drive. it got to 100% and my pc locked up. I left it for a bit but nothing happened, so i had no choice but to reboot the system. Drive now seems to be dead. On reboot, the light doesnt show and pc wont boot with it still connected. If i disconnect the ide cable and power it boots, when its connected again, it doesnt. Is there anyway to bring it back to life, or is it dead for good now ?

Never had a problem with flashing before, but this drives been a real pain, now its gone forever i think, and only 2 days old :frowning:


#7

Not necessarily!

Let me do a little research… I remember something about a DOS app that may let you flash “dead” Sony/LiteON drives. Should have something for you shortly.


#8

ok mate. how can it flash it though if it cant see it and cant boot with it attached ?


#9

OK, first up sorry my suggestion caused you so much trouble. As you said, I’ve never had trouble flashing a drive before, though it’s one of those things that’s always in the back of your mind as a potential problem. The good news is, if you have a floppy drive it’s relatively easy and if you don’t it’s still possible with a second optical drive connected.

Here’s what you do:

Download mkflash 1.80:
http://dhc014.rpc1.org/Files/mtkflash/mtk180.zip
Download this boot-floppy creator:
http://digi.rpc1.org/download.php?site=spcl3d1&file=DOSboot_flopmaker.zip

Now, if you have a floppy drive get a blank and use the floppy creator to make it boot DOS. Unarchive and the MTK180 files to the prepared floppy as well as the backup of your original firmware you made before flashing (something.bin) – make sure to shorten it to something easy, DOS doesn’t like long file names. Shut down.

[B]Set the drive as slave and put it on your secondary IDE channel, alone, but disconnect the power from it.[/B] Leave the side off of your case.

Boot from the floppy you created and type DIR, taking note of the name of your firmware, something.bin. Reconnect power to the DDU1615 – yes, I know this is generally stupid, but here it’s the only way to get the machine to boot, and the drive is already “dead”, so do it anyway. Once the drive is plugged back in type:

[B]MTKFLASH 4 W /B /M something.bin[/B]

Breakdown of the options used:
4 tells the program it’s the slave drive on the secondary IDE channel
W tells it to write
/B tells it the image is in binary format
/M tells it the image is multibank, read from one file
something.bin should obviously be changed to whatever you called the file on the floppy.

Press enter, wait for the flash to finish, and reboot. The drive should again be recognized as a Sony DDU1615.

If you’re still feeling adventurous (I doubt it, but here it is anyway) you can get rid of your rip-lock by modding the backup .bin you just flashed with OmniPatcher and reflashing the drive (with MKflash this time, as it is apparently safer/more stable, though I’ve never had trouble with the Windows app…) to unlock it.

[B]BUT WAIT, I DON’T HAVE A FLOPPY DRIVE![/B]
In this case you have 2 options.
The first is to steal one from somewhere for the purposes of this little project.
The second is to make a bootable DOS ISO with a writer and include MKFLASH and the firmware backup.bin.

If you can’t get a floppy drive tell me, and I’ll work out just how to make this ISO. Otherwise, best of luck.

-[I]silence[/I]


#10

[B]Assuming you don’t have/can’t easily get a floppy drive, but have access to a CD-RW drive[/B]:

Put MKFLASH and the .bin firmware backup you’ll use in to an easy to get to folder like C:\firm then burn the files in this archive http://www.loveandstitches.com/digital/floppy.rar on to a bootable CD compliation with Nero or similar.

Boot the CDR in another drive, then once in DOS type:
[B]cd C:\firm[/B] or wherever you put the files
then:
[B]MTKFLASH 4 W /B /M something.bin[/B]

If you can’t access your C: drive after booting off the CD, type:
[B]autoexec[/B]
and it should work. Since I’m using files originally intended for a floppy on a bootable CD I don’t know if the autoexec.bat will run as intended, and therefor if the NTFS/DOS drivers will load. If it doesn’t that’ll force it.


#11

Also of note: If the machine still won’t boot with the drive connected you can disable the secondary IDE channel in the BIOS and it should boot but not see the drive. This is OK, since MKFLASH ignores the BIOS information anyway and will flash the drive regardless, as long as you point it to the correct channel and master/slave.


#12

thanks mate. I’ll try that in the morning and let you know what happens. Iam too tired to do that tonight and theres a good chance i’ll electricute myself, lol


#13

I followed your advice but still no joy.

I made the boot disk and put mkflash.exe and my firmware on it.

Attached the dead drive to Seconday slave, and booted to dos.

Typed in the command mtkflash 4 w /b /m gys1.bin
started to flash and got to

updating 00%

And thats as far as it goes, it sits there doing nothing.

Any other advice, or is it dead forever ?


#14

it sounds awfully weird that the 1615 has a GYS1 firmware.

I bought mine last year and it came with FYS2.

Is it possible that there is a new 1615 based on the 16P9SV?


#15

ummm, are you sure its not a ddu1611??? I just got a ddu1615 and it had FSY2 on it and I uped it to FSY3 w/o any hitches…


#16

http://club.cdfreaks.com/showthread.php?t=152782


#17

Nope its defo a 1615. I bought one last year which had the FYS2 firmware, which is why i though it was weird to have a 1615 with GYS1 firmware. I checked for GYS1 firmware on google and it was showing me the 1611. My PC’s reads it as a 1615 and it says on the drive Sony DDU1615-B2, but if i try and use .exe firmware, it says This firmware is for Sony DDU1615 only, Sony DDU1615 Not detected. Drive was bought from www.ebuyer.com - Dead strange. Glad iam not the only one that thinks so though. I think thats why ive killed the drive. Didnt know weather to flash it as a 1615 or 1611 and all the firmware i’ve tried doesnt recognise it as either ?


#18

your previous drive with FYS2, does your drive label (physical sticker) says 1615-B2 as well?

I don’t recall the B2 part on my drive sticker.

You might want to take out your older drive and see if it’s a B2.


#19

Think the B2, just means a black front drive. The silver ones are DDU1615-S2

Ive bought another Sony DDU1615 now, and hope it comes with FYS2 firmware and not GYS1. Got this one from a different place so i dont get one from the same batch.


#20

Sorry to hear it didn’t sort out. Like I said before, this is the first bad flash I’ve ever run in to. Hope you have better luck with this new drive.

-[I]silence[/I]