Sony BWU-100A Blu-ray drive ripping problem - PLEASE HELP

I have been using Anydvd and DVD Shrink rips all my regular DVD without any problem. I just bought a Sony Blu-ray drive bwu-100a and installed it.
I can play regular DVD without any problem.
But when I tried rip my first Blu-ray DVD to my HD, I failed. About 60% or so it tells me something like a region code problem of some sort and tell me go to rp1 to download the latest driver. I did and I do have the latest driver. Any one have any idea why? Reboot few times already but no luck… Please help.

Many thanks in advance!

Anydvd HD version6.1.6.9

Why should this have to do anything with DRIVERS?

Region codes have to do with regions and their protection scheme, the same as with dvd drives.

What is your settings on the AnyDVD Video Blu-ray? Did you choose to “Remove Blu-ray Region Code” as in the picture below?


It was blank out before. I just try to check that and l’ll give it a try now. Will let you know. Thanks!

Guys,

False alarm! Sorry it was a bad Blu-ray disc. Just tried the 2nd Blu-ray and it worked without any problem. Case closed.

Thanks for all the help!