Sony aw-q170a doesn\'t recognize all DVDs anymore (Optiarc AD-5170A)

vbimport

#1

[qanda]This thread is about the Optiarc AD-5170A. Click here to see full specs[/qanda]I have a Sony AW-Q170A or as I understand it a Optiarc NEC AD-5170A. Anyway, I’ve had the drive for a little over half a year now and it just recently will not recognize my DVDs. Except, I left this one DVD in it for awhile because the game (FEAR) needed it for me to play. It will read this DVD every time without fail which is confusing because I’ve tried multiple DVDs and they are not recognized. So I read multiple posts on this issue and I flashed the drive with the one provided by the Sony site as well as the one from Libby’s. Went into safe mode etc. Still nothing but it still plays that FEAR disk without fail.

Suggestions?

On a side note I was so pissed off I bought a LITEON from NewEgg but I would love to keep my Sony working.

Thanks for any help! :smiley:


#2

If you’ve notices that it’s only DVD-R disks that it cannot read, it might help to flash the drive with this firmware…
Liggy’s AD-5170A Bitsetting Firmware 1.13(google for it)
I’m saying this because, i have the same drive and had the same issue, and this fixed it… hope it works for u too!