Sony AW-G170AB2 will not read burnt DVD data discs

vbimport

#1

I have a new DVD Burner, a Sony AW-G170AB2 .

After installing it (as a master, it is the only drive on the second IDE channel) I tested it by burning a DVD, all went well. I then was unable to get the drive to read the burnt DVD and had the same result getting it to read previously burnt DVDs burnt on my old burner, for some reason it seems to recognise them as CDs with nothing on them. All these DVDs can be read by my other PC DVD ROM drive so they have definitely burnt OK.

I then tried to burn a CD which was a success, it could also read CDs without a problem.

Before sending the drive back as faulty I installed it in my old PC. Annoyingly (in some ways!) it was able to read the very same DVDs that it could not read in my main machine without any problem so I have concluded the drive must be OK and I am shying away from it being a media issue. I’m thinking there is some kind of problem with the system I want to use this drive in. :confused:

In short this drive will not read burnt DVDs (but will burn them OK and read/burn all CDs) in my main machine, the very same DVDs are read by this drive without issue when it is put into my spare (and very old) machine.

So far I have tested it using a different IDE cable (in fact the one from my old machine in which the drive works perfectly). The nforce 2 drivers have been rolled back to the original ones that came with the mobo and updated to the latest ones. A firmware update has been attempted but the process fails. The jumper settings have been set up correctly and I have checked the transfer mode is DMA. Nothing has made any difference.

The trouble is I have no idea where to go now as this situation is new to me.

Hopefully someone out there has an idea of where to begin. :smiley:

The system I have is:

Athlon XP 2800
AN78X Mobo
1.5 Gig ram
Asus 480 Watt Power supply

If you think any other info is relevant please ask.

Thanks.