Sony 52x oem goin crazy, and no one to help me!

vbimport

#1

I recently purchased a Sony 52x cdrom (CDU5211) which I found to be an oem after I recieved it. The trouble is that when I tried to use the drive, it screwed up data that it tried to read. Then, when I tried to play/rip audio tracks off of it, it locked up the entire system. Thinking that this was some sort of manufacturing defect, I contacted the online company that I purchased it from, and after a smidge of long-distance squabling, I managed to get an RMA# to return it. After recieving the new drive (same thing, different drive), it is doing the same thing. Thinking something might be wrong, I went into the cdrom properties, and disabled the digital audio option, and it will play audio now, SORT OF. When it does play, it plays the audio INCREDIBLY quietly, to the point that when my speakers are turned up all the way you can sort of hear it, but not really over all of the static. I did however notice something quirky: when trying to explore my Diablo II expansion cd, it only reads it as an audio cd (it’s a hybrid cd, which is normaly read as a data cd), and has audio tracks listed. Thanks for ANY help, and no Sony won’t support the drive since it’s OEM.