Sony 400-Disc Blu-ray Megachanger Coming in August

Sony has announced two Blu-ray megachangers — the BDP-CX960 and BDP-CX7000ES that hold up to 400 Blu-ray discs, DVDs and CDs.

Link: http://www.cepro.com/article/sony_400_disc_blu_ray_megachanger_coming_in_august/K294

:cool::cool:

Picked up the BDP-CX960, plays the disks really great (When found) but I’ve got 19 out of 68 disks installed not recognized… of the Alien VS Predator set it recognizes the first disk but not the second disk (Requiem), burned a copy of another disk that was invalid but it didn’t recognize that one either.

At this rate it going to have 100 invalid disks when full.

Anyone else get this machine yet? I need to compare results

Thanks

Are we talking backed up copies or originals?

DvD’s or Blu-ray’s ?

Are you running the most recent firmware version for the BDP-CX960?

If you are using backed up copies, What is the media brand and the MID of the media?

I personally don’t own a 400-Disc Blu-ray Megachanger, but from browsing through some comments here.

http://www.hometheatershack.com/hometheaterstores/bluray-players/sonybluray-352697011-B002M78J70-Sony_BDP_CX960_400_Disc_Blu_ray_Disc_DVD_MegaChanger_Black.html#reviews

I found many describing your problem, But nobody gave a probable solution.

I noticed one recurring theme about the unit scratching the media. Are you having any issues with that?

:cool::cool:

It’s with both backups and originals tried both. Backups are with TDK25G smooth edge and rough edge type, 4X TDK 50G 4X But other backups with same disks work fine can’t find a rhyme or reason. Suspecting the machine after trying so many combination’s.

Thanks for the quick reply

I found a review at Amazon for the BDP-CX960 and this guy said it only had a couple of invalid disks until he installed the latest firmware update (012). After returning to the original firmware they all came back.

I forgot to mention that I updated mine to the(013) firmware.

It doesn’t come up with invalid disk for all the blank media types.

Here is the DVD Identifier file infos of my blank media:


Unique Disc Identifier : [BD-R-DL:TDKBLD-RFB-000]

Disc Type : [BD-R DL : Class 0 - Version 1]
Manufacturer Name : [TDK Corp.]
Manufacturer ID : [TDKBLD]
Media Type ID : [RFB]
Product Revision : [000]
Stamper Date : [Not Present On Disc]
Layer Info : [2 Layers (L0-L1) : 25.03 GB (23.31 GiB) Per Layer]
Blank Disc Capacity : [24,438,784 Sectors = 50.05 GB (46.61 GiB)]
Recording Speeds : [1x , 2x , 4x]

[ DVD Identifier V5.2.0 - http://DVD.Identifier.CDfreaks.com ]

the second one


Unique Disc Identifier : [BD-R-SL:TDKBLD-RBB-000]

Disc Type : [BD-R SL : Class 0 - Version 1]
Manufacturer Name : [TDK Corp.]
Manufacturer ID : [TDKBLD]
Media Type ID : [RBB]
Product Revision : [000]
Stamper Date : [Not Present On Disc]
Layer Info : [1 Layer (L0) : 25.03 GB (23.31 GiB) Per Layer]
Blank Disc Capacity : [12,219,392 Sectors = 25.03 GB (23.31 GiB)]
Recording Speeds : [1x , 2x , 4x]

[ DVD Identifier V5.2.0 - http://DVD.Identifier.CDfreaks.com ]

Another


Unique Disc Identifier : [BD-R-SL:PHILIP-R04-000]

Disc Type : [BD-R SL : Class 0 - Version 1]
Manufacturer Name : [Philips]
Manufacturer ID : [PHILIP]
Media Type ID : [R04]
Product Revision : [000]
Stamper Date : [Not Present On Disc]
Layer Info : [1 Layer (L0) : 25.03 GB (23.31 GiB) Per Layer]
Blank Disc Capacity : [12,219,392 Sectors = 25.03 GB (23.31 GiB)]
Recording Speeds : [1x , 2x , 4x]

[ DVD Identifier V5.2.0 - http://DVD.Identifier.CDfreaks.com ]

Final point The seller is taking it back and going to send me another new one.
Here’s hopin’

Thanks.

Well replaced the bdp-cx960 but still have the same result. A hodgepodge of disks that don’t work.

Even did the 014 firmware update still same problem.