Solving a problem with Asus DVD S-Multi DL 8X/6X/5X/24X PCC UJ 850UAL1-A-1.22 HW: 1.03



Hello, I need help solving a problem with my Asus DVD S-MULTI DL 8X/6X/5X/24X 17G141121103 or Asus DVD S-Multi DL 8X/6X/5X/24X PCC UJ 850UAL1-A-1.22 HW: 1.03 is the same unit. I need the firmware, or a solution to accidentally change the firmware installed, TSST corp CDDVDW SN-S082H SB01. thank you :doh:


Hi and Welcome!

could you please describe your problem more in detail? Perhaps there is another solution than a crossflash attempt with questionable results.

PCC UJ 850UAL1-A-1.22 HW: 1.03
is most likely a Panasonic drive.
is totally unrelated.



Hello, thanks for the help. My problem is as follows:
I have an Asus F3SR with a CD / DVD ASUS DVD S-MULTI DL 8X/6X/5X/24X 17G141121103 and when I tried to install software for virtual drives that software has changed the firmware of my drive. Now does not recognize any CD or DVD is recorded or blank. To solve the problem I tried to install another firmware but the problem continues.

Optical Drive:
Asus DVD S-MULTI DL 8X/6X/5X/24X 17G141121103 or
Asus DVD S-Multi DL 8X/6X/5X/24X PCC UJ-A-850UAL1 1.22 HW: 1.03

Firmware Installed: corpCDDVDW TSST SN-S082H SB01-

Status: Does not recognize CD or DVD discs.

Thank you for availability.


The optical drive is correct: Asus DVD S-MULTI DL 8X/6X/5X/24X 17G141121103.


As mciahel has pointed out, if the drive you have is the TSSTcorp (Samsung) drive, that is NOT the same as the drive with the part number 17G141121103; that part number belongs to a Matshita (Panasonic) UJ-850U. Whatever Windows tells you is the drive you have; if Windows tells you that you have the TSSTcorp drive, you have that drive. If Windows tells you that you have the Matshita drive, that’s what you have. Computer manufacturers tend to use multiple sources for parts, so not everyone gets the same model optical drive or hard drive (though the Asus part number may be the same, since they serve the same purpose).

Installing software for virtual drives cannot change your firmware. As long as you have not tried to flash any different firmware to the physical optical drive, you do not have to do anything dealing with firmware whatsoever.

What software did you install to create the virtual drives?


Thanks for the help.
In January 2011, have performed a major overhaul of my notebook: Asus F3SR.
The brand has replaced some components, including the optical drive, the repair invoice have the launch of the euro:
Reference: 17G141121103
Description: DVD S-MULTI DL 8X/6X/5X/24X.
Everything worked fine until you try to install a software virtual disk (which I do not remember, because as it did not work, I ended up deleting the application), it crashed. However I bought an external drive from Asus. But this internal drive there and tried to repair it.
If the installation of virtual optical disks can not change the firmware then the original firmware was TSST corp CDDVDW SN-L632H_AS04 SB01.
While trying to repair the firmware installed: TSST corp CDDVDW SN-082H SB01.
But still all the same, does not recognize any disc.
Any help is very welcome, once again thank you.


So, to make sure I got this right, you got an external drive, tried it, and it did not work?

Try installing the burning software ImgBurn (, a free program frequently recommended around here when troubleshooting). Once you install ImgBurn, use it to delete what are referred to as “the Upper and Lower Filters”, if possible. Launch ImgBurn, click Tools >> Filter Driver Load Order, select each Upper and Lower filter and click “Remove Selected”. (I am using this post as a basis for my instructions). Please report back on whether that helps or not.


You can go around in circles trying to fix Hardware or Software problems. Going back to basics is the best solution, so I would recommend using System Restore to go back to a time your Laptop was working good. You talked about doing things back in 2011, so this might not work. I work on computers all the time and don’t like wasting my time trying to find solutions. I save the Data and Format and Reload the Operating System. Your Laptop calls for Vista, so if you are not running Windows 7 this might be a good time to load this OS. :cool: