[Solved] NeroLINUX not finding USB DVD+/CD-RW drive Fedora Core 3

vbimport

#1

First: kudos for the Linux verison of Nero – a most welcome and appreciated product, and one which works where K3B / cdrecord failed. Nero allows me to finally use my USB drive with Gentoo.

However, on the same hardware (I use a removable disk drawer to swap OS), with Fedora core 3 the drive is not shown in the “choose recorder” panel.

Some (hopefully) useful particulars:

The drive is an an IOmagic IOM-601. The fstab entry for the drive maps /dev/scd0 to /media/usbdvd; the drive mounts successfully (and automatically) with this fstab entry. The owner and group for /dev/scd0 are my user and a group to which that user belongs.
I’ve tried running Nero as root, but the drive still doesn’t appear.

On Gentoo and Suse 9.2 pro (Suse on different hardware) the drive appears as /dev/sg0. Running ls -l /dev/sg* on the Fedora system returns: ls: /dev/sg*: No such file or directory.

Any pointers where to look or what to change to encourage the drive to appear?

Thanks!


#2

If the drive is mounted when NeroLINUX starts, it will not be available. So first you should make sure that this drive is not mounted before starting Nero.

Secondly, if you does not see any sg device in your /dev dir, make sure that the SCSI Generic Support module is loaded at startup. This might be helpful.


#3

Loading the sg module fixed the problem. Apparently hotplug was loading sr_mod, which didn’t build the /dev/sg_ entries.

Thanks for the solution!


#4

How did you loaded the SCSI Generic Support module.


#5

Assuming the SCSI generic support module was built as a loadable kernel module (which was the default for my installations):

modprobe sg