SOHW1653s firmware

I was trying to update the firmware of my SOHW1653S form the CS02 to some of the newest CS0R or CS0T, but in both cases after flashing the drive was not able to recognize DVD-/+ R media at all (noise + Nero report “no media inserted”. At the same time CD-R, CD-RW and DVD+RW recording worked normally. I got CS0T from the LITE-ON site and CS0R from codeguys. Downgrading back to CS02, resolved the problem with DVD-/+Rs. Is there any way to use the newest firmware versions? Does the ability to use CS0R or CS0T depend on the manufacturing date of the drive (mine is October 2004)?
Thanks a lot in advance.

My 1633 is manufactured August 2004 and works fine with CS0T…???
As I flashed CS0R it happened to me that the drive did not recognise cd-media (and maybe dvd-media as well, I did not try). Flashing back to BS0S solved the problem. Then I flashed with a new downloaded copy of CS0R and everything worked o.k. Don’t know why that happened, but maybe it’s an idea to try again with a new downloaded copy?

:confused: Leo