SOHW-812S problem with updating firmware

Hi. This (See picture) happens with the US0N firmware. So I tried US0G and got the same error.

The reason I tried to update is because the drive burns CDs/DVDs but they arent readable. Figured that might help. But it wont work.

Is the drive broken? Or is there some way to fix it?

Thanks

You may need to manually flash the bin file using LTNFlash…

I’d suspect an IDE cable problem.

Thanks.

Replacing the IDE cable allowed me to update the firmware (And it also shows the correct drive name now) but the drive is still useless.

It burns (Without the red light on) but the CD/DVD will still be blank afterwoulds. It doesnt have any problem formatting (The red light comes on here).

Another note, as Im not sure if this should happen or not, is that during burning the Buffer stays on 50% all the time.

Why does LtnFlash (v1.2.4) fail on my 812S? When trying to flash the f/w
the status bar immediatly jumps to 100% but nothin’ else happens. LtnFlash
totally locks up, can’t be killed by using the taskmanager and even Windows
(2kSP4) refuses to shut down.
This strange behaviour can be reproduced. It worked flawlessly with my old
811S which was connected the same way (same cable etc.).

Any ideas?

While typing this…
The 812S ist jumpered as master, maybe the 811S was jumpered as cable select.
I’ll give it a try.

[EDIT1]
The official exe-flashers work, though.
[/EDIT1]

[EDIT2]

  • cable select doesn’t change anything
  • reading the firmware/EEPROM works
  • writing the firmware using LtnFW works, too

Well… Only writing (updating) the f/w using LtnFlash seems to fail.
[/EDIT2]

AFAIK, you’re not the first person reporting problems with updating fw with LtnFlash. Use LtnFW, as it works just fine. LtnFlash can be used to backup EEPROM.

DiggnSaeg

I seen that too i think they changed something in flash rom on the drive , i used the fw only flasher in tools section it works everytime.

VAD

I have had two 812s both feb 04 the first was ok with ltnflash 1.24 the second eeprom area worked fine but fw would not flash with it. I found I had to use the cdf tools page fw only flasher then it worked fine. I really dont know why this is but a friend down the block also could not flash with ltnflash on his 812 march 04 and I showed him the fw only flash and it worked fine too.

I think maybe flash ram may be not all the same batch or quality

I don’t think that’s the case. LtnFlash is pretty old, and LtnFW is newer. He’s reported back saying that using LtnFW did the trick. This is not the first time a problem has been reported with LtnFlash and that using LtnFW helped (in fact, C0deKing has always had to use LtnFW for his 451S because of problems with LtnFlash). I think it’s probably just a bug or something. shrugs

use the exe from liteone or the patched one, to see the drive you have to kill the aspi layer conflicting. Otherwize the windows program can’t see the drive…

to kill aspi, dl forceaspi. Killaspi is in the package