SOHW-1693s only recognizes DVDr not CDr

Upgraded the firmware. After disc spins awhile the green light blinks 2x, pauses, blinks 2x again, pauses and blinks 2x once more. All programs see drive as empty. Put in a DVD no problems. Any help?

Uninstall the IDE channels in Devicemanager, then restart.

Thanks Chef for trying to help. I tried your suggestion with no resuts. (win2000 just reinstalled ide channels. This was predictable, since I already tried this drive on another PC. As I said - if I just plug Power cord (IDE cable disconnected) - it still cannot recognize any cds/cdrws/audio cd’s. It spins them for 3 times, trying to initialize the root track (I disassembled the drive to see what heppens) , than stops the disk.
This must mean that the problem is with drive itself, not in software or drivers, at least in my case. Any proposals?

When you said, “…Upgraded the firmware…” Are you referring to the latest, stock fw?

junglemike,

same trouble in another computer with this drive??

Thanks. I did read post and uninstalled the IDE controllers in Device Manager, no luck. I upgraded the firmware from the Lite-On site after this problem occured.