SOHR-5238S dead?

vbimport

#1

Bought a new SOHR-5238S today and tried to update the Firmware from 4S06 to 4S07. Unfortunately the machine I tried on flashing the drive, had an asus deluxe mb with NVidia Chipset on. :a So the flashing process stopped at 41 % and a message appeared: “Error while flashing Firmware. Please contact your vendor”. Duh! Now my drive shows up in WIndows XP and in BIOS but the eject button doesn’t work anymore nor the LED. :sad:

I tried using the official flasher from liteon again on another machine with via chipset and MS drivers. it went to 100% but then stops. Close button stays grey…

I don’t have a backup of the original firmware. my fault…
but is my drive really dead (since it shows up in the BIOS and even in WIN is can’t be?!?!). I searched around the net for a bin firwmare file. Extraction with litefirm and another tool (forgot the name) failed, since the flasher is compressed. :Z

So what else can I do now? Does anybody have the same drive an would be so nice and pass me the bin file, so i could try mtkflash?

Cheers

Trance


#2

use mktflash and falash it thru DOS …


#3

Oh man, that sucks. Well, unfortunately, that’s the danger of flashing in Windows–a very hostile environment in terms of communicating with drives.

Normally, I would recommend a MtkFlash (there are ways to obtain unscrambled firmwares) recovery, but there’s a problem here: your drive’s unique calibration data is stored in the firmware itself. So I don’t know if this would be a good course of action to take.

My recommendation is to contact LiteOn tech support, tell them that the drive misflashed, and they will most likely have you send the drive in for a replacement.

It also sounds like your drive was only half-flashed, so if you can’t get a replacement, there may still be another way around this, since the calibration data is stored near the beginning of the firmware and not at the end… but I would recommend pursuing the replacement-for-misflash first.