SOHD 16p9sv - some problems

vbimport

#1

SOHD 16p9sv

I bought this dvd-rom drive because my old lg (hl-dt-st 8160b) stopped reading dvds… But there is a little problem…

The speed for DVD+/-R/DL is locaked at 8x. I modified my firmware and tried to flash it… But here is where my problem begins.
I can read the firm using some windows tools (ltnfw, ltnflash) but I can’t write it (both tools just hang). Mtkflash (tried 1.80 and 1.83c) can’t even read anything (v1.80 stops at Reading: 00%, 1.83c stops at something like controler: 1f0, master/slave: a0). I tried on all the configurations ide1/2 master/slave. Still nothing. Mtkwinflash says “err: unknown flash type” - or similiar. Reading at 8x really sucks.

Coud someone help me with this problem, please…

I’m also using Seagate Barracuda 120Gb hdd, liteon shw-16h5s writer, Abit nf7 v2.0 mainboard (nForce2). I tried connecting only SOHD 16p9sv on pri master. Can’t do anything.

Did anyone run into similiar problem? I can flash my shw16h5s writer with no problem. (well, not using the ltnfw, and ltnflash - they still hang, but the original flasher is working fine)

Thanks in advance.


#2

You might try here, when their server is back up:

http://codeguys.rpc1.org/firmwares.html


#3

It was the first place I tried to download the firmware from (unfortunately it’s down for some time). Still wondering why the mtkflash doesn’t work with my drives (does it mean I won’t be able to recover from bad flash etc.?)


#4

Nevermind… I was able to flash my drive using firmware from http://codeguys.rpc1.org/firmwares.html

I still can’t use any other flasher. May it be connected to the fact that I never had to use any antiblacklist tools for SD4? It always was working fine without it. In fact I can play Starforce protected games backups without disconnecting my drives… Is this mobo? Ide controller? Bios settings? Or just my drives…