SOHD-16P9S firmware mod

vbimport

#1

Can anybody do that?
BTW is there any updated firmware for this drive?

Moderator’s note: For people who are looking for the post in this thread where the patch is released, here is a link to post #84.


#2

Hey were have you been?

You went to other side (BenQ?, NEC?)

If so, then we don’t help you anymore.

:wink:


#3

No… just found a job :Z but hey, I have my own house (and wife btw) si I need (among other things) to eat, drink and take photos… all of which are expensive.

But thanks for asking :wink:


#4

Hey Maurice. I own a BenQ and a NEC. Should I go as well :p:).

thibouille, I guess your looking for a read speed patch?

Edit: There finally is one available now…
See post #84 of this thread…


#5

I’m looking for a speed patch. I’m dying without it! Any guess at an ETA for the 16p9?


#6

Yes, that’s what I am looking for.
A speedhacked/RPC1 modded firmware :slight_smile: :bow: :bow:

Or a utility so I can make my own, would be cool too :smiley:


#7

Doesn’t LtnRPC or KProbe do that bit already?


#8

Sure, it is not of a great importance.
But speedhack is really needed :slight_smile: :iagree:


#9

thibouille and Unsavior, what do you think of the SOHD-19P9S so far. A lot of people are interested in this new DVD-ROM drive.

1/ Is it a good drive?
2/ Is it quiet?
3/ How does it handle different media?
4/ What does it look like?
5/ Is the tray gear driven?
6/ What are the default rip speeds (+R, -R, +R DL, DVD-Video…)

Thanks. :slight_smile:


#10

I didn’t have time to test it.
It seems a bit slower maybe a bit worse than my old 163.
But sure it is more silent and I LOVE the way the tray opens/closes, sooo softly :smiley: :D.
Of course it is small as usual Liteon products since LDW-401 -> about 2cm smaller than my 163.

Will test ASAP.


#11
  1. can’t tell yet…PI/PIF tests are interesting to say the least
  2. reasonably
  3. I’ll post a link to my tests later on compared with lite-on 166s
  4. looks the same as all other dvd-rom/other litey drives. has same sort of faceplate. has a single eject button, no cd-audio play button.
  5. looks like a belt driven tray. i’m no expert, but when i look at my 52327s, which i can see only has gears, the 16p9s has a small black (rubber?) line that moves when the tray opens/closes. i assume this is the belt.
  6. i’m looking into it right now.

#12

used LtnFW to backup my current firmware before the FS09 upgrade (no other prog would work)
i uploaded some comparison scans and speed tests - http://dice.zapto.org
pressed DL/+r/-r reads at 8x
pressed SL reads at full 16x


#13

Whats the fastest ripper for Dual layer discs available? The AOpen DVD1648/AAP??


#14

Thanks dicer :). Definitely better at scanning.

My initial look at the firmware showed just the two speeds. Now if only I could figure out a safe way to flash the drive with the patched firmware I have. I wonder if the DOS MTKFlash works with this drive…


#15

I decided just to get a AOpen 1648/AAP Pro since I had some money to blow. I will keep the 16P9S in my closet just in case. :slight_smile:


#16

Ok i re-tried MTKwinflash and it should work. My first attempt with it didn’t seem to work because i thought it crashed while trying to detect the drive, BUT it just takes a while and the program doesn’t respond. I just had 2 more attempts to detect it via atapi, first time went fine and the progress bar was updated correctly. The second attempt was the same as my original attempt, it just stopped responding, but after waiting a couple of mins it came back to life. I then tried to send a flash file…but the only file i had was the one i dumped with LTnFW, which it didn’t like (thankfully it didn’t try to flash :p)

what 2 speeds are they ?


#17

I just did a scan of a +rw and yes, 8x read speed there too confirming what you had seen. If you have any firmware you’d like me to test on this drive Please PM me :slight_smile:


#18

Dicer, at the moment we haven’t found a way to flash unscrambled firmware into the drive. LtnFW does not work and neither does our flasher. Are you prepared to try and see if the DOS MTKFlash still works. You could try flashing your original firmware backup. If this works then the patched firmware can be loaded by the same method in the interim until another solution can be found. Unfortunately there is some risk involved. I don’t have access to a drive myself and they are not in the shops here yet.


#19

OK, so that file that i took in from LTnFW may work using MTKflash…will look into it…


#20

Doesn’t work :frowning: no response through dos. DOS MTKFlash is working on my 52327, but not the 16P9S. I also tried that DSP Read, it made a file filled with 0’s :confused:

Since it cannot read from the drive i don’t think it’s worth trying to send to it. unless there have been times in the past that it could send and not receive…