Softmod Issues Ripping

Ok guys I tried to read the TOS and I hope Im not violating anything here. I have some issues and Im hoping you guys may be able to help me out. My friend softmodded my Xbox a few days ago and locked me an 80 gig HD Western Digital 7200 RPM. The day he finished I attempted to backup some of my games to the HD. Out of 17 games I am succesfully able to play only 5 of them.

The following is a list of the titles that I attempted but failed:

Harry Potter and the Prisoner of Azkaban-Plays but characters move really fast and the cut videos move fast also.

50 Cent Die or Get Rich Trying-Locks up at loading Screen

Harry Potter and the Goblet of Fire-WIll not play at all black screen lock up

Tony Hawk American Wasteland-Loading Screen Lockup

Wasted-Loading Screen Lockup

Tony Hawk Underground 2-Loading Screen Lockup

Land of the Dead-Locks up on very first video before it loads in game

Outlaw Golf 2-Locks up on Loading Screen

Dynasty Warriors 3-Wont play at all-Black Screen Lockup

Theres a few of them…now here goes my question. Do you think its possible that my harddrive is messed up? I mean to me I would think if there was hard drive issues no games would go in. Secondly could it be dirty disc eye in the xbox? I havent attempted to clean it but thats my next step is to try a CD doctor.

I have used both the built in Game copier and the Application to rip DVD to HD with no success on any of these. Is it possible my settings are wrong??

Sorry about rambling, I would really appreciate any help on this matter.

Thanks
Kaine-