So I killed my DW-D22A

vbimport

#1

Hey all, great forum here. I’ve tried to use the search function but couldn’t find the same problem, so apologies if this question has already been answered.

Per the title, I have the Sony DW-D22A drive, and I came into possession of some blank Verbatim DVD-R 16x discs, which the drive would not detect. The 8x discs that I had last go around worked great, and the drive has been working fine.

I figured as the 16x discs could not be read, the drive was due a firmware upgrade to get around this (hasn’t been touched since I got the drive 18 months ago).

So I read up and found my drive was an equivilant to Sony DRU-710A, and grabbed the BYX4 stock firmware from http://codeguys.rpc1.org/firmwares.html. Ran the exe file, rebooted the machine when it asks me. Windows boots back up, hey presto, Device Manager detects a DRU-710A. I’m even thinking of cross-patching to the Lite on at this point, BUT … I look at the case and the LED for both the DVD drive and the hard disk drive are flashing away in sync.

DVD drive is now not reading any DVDs or CDs, blank or otherwise. No conflicts are showing in Device Manager, “DMA mode if available” is set on both IDE channels (the drive is slave to a HDD on channel 1). If I try to run Disc Info in Nero it eventually says “No disc inserted or drive not ready”.

I’m guessing the blinking LEDs for both the DVD and HDD are because they share a IDE channel, I’ve checked the cabling is secure in the case, but I’m not at all sure what to look at next. Anyone ready to help me please?


#2

Welcome to cdfreaks :slight_smile:
It is not so easy to kill a Liteon drive. Your drive is up and running and just complaining that the used firmware does not match. Take this patched firmware and everything is fine again. In case the disks are detected but the led does not work as it should, load the stock BYX5 firmware with omnipatcher, enable crossflash and flash again.


#3

That worked great, thanks so much for your help!


#4

Ok sry for making my first post a problem but… :sad:

Same kinda problem. Last year it wouldnt burn verbatim 16x dvd + r so i updated firmware to bsy3. It worked tillll…

Now when i come to burn again (with different batch of verbatim 16x dvd + r) the burn software just says “either this drive or this disk is not ready”.

So I install Byx 5 turning it into a 710 A like copps but it wont recognise any disk in the drive. Then seen your remedy, tried it and obviously failed. So now I :sad: .

No problem concerning leds though.