SN-506BB not reading audio CDs or Blu-rays

vbimport

#1

I have a new MSI WT60 2OK laptop fitted with a TSSTcorp SN-506BB ODD. I installed Windows 8.1 and various supplied MSI drivers using the ODD but then found it wouldn’t read audio CDs or Blu-rays (PowerDVD, VLC). Tried in safe mode but no better. Vendor suggested re-install of OS. I tried CDs before and after installing the MSI drivers - again made no difference. i also tried an install of Ubuntu 14.04, but again no joy. If I connect an external Plextor USB Blu-ray ODD, that will work with all media.

Summary from DiscInfo:

DISCINFO VERSION : 1.6.1.6
VENDOR : TSSTcorp
MODEL : BDDVDW SN-506BB
REVISION : TM01
VENDOR SPECIFIC : 1211
LOADING MECHANISM : Tray
SERIAL NUMBER : ***********
NUMBER VOL. LEVELS : 256
BUFFER SIZE : 4096KB
TOSHIBA CODE : OEM TM
TOSHIBA MODEL :
INTERFACE : ATAPI
RPC2 SCHEME : YES
STATUS : Set
USER CHANGES : 4
VENDOR CHANGES : 4
CURRENT REGION : 2
ANALOG AUDIO PLAY : YES
COMPOSITE OUTPUT : NO
DIGITAL PORT-PORT1 : NO
DIGITAL PORT-PORT2 : NO
READ UPC CODE : YES
MULTISESSION READ : YES
MODE 2 FORM 1 : YES
MODE 2 FORM 2 : YES
READ ISRC CODE : YES
READ BAD CODE : NO
BUFFER UNDER-RUN : YES
MT. RAINIER : NO
CAN READ CDR : YES
CAN READ CDRW : YES
CAN READ CDRM2 : YES
CAN WRITE CDR : YES
CAN WRITE CDRW : YES
CAN TEST WRITE : YES
CAN READ DVD-ROM : YES
CAN READ DVD-R : YES
CAN READ DVD-RW : YES
CAN READ DVD-RAM : YES
CAN READ DVD+R : YES
CAN READ DVD+RW : YES
CAN WRITE DVD-R : YES
CAN WRITE DVD-RW : YES
CAN WRITE DVD-RAM : YES
CAN WRITE DVD+R : YES
CAN WRITE DVD+RW : YES
MAX CDR READ SPEED : 24
MAX CDR WRITE SPEED: 24

I can’t locate a copy of the firmware on the TSSTcorp or Samsung websites - only an older version (can’t find drive). Does anyone have any suggestions before I return the laptop to the vendor?

Thanks


#2

If the firmware update found at this MSI link can’t find the drive (due to the download being the same or older version) or fails to help, then I suggest you just return the laptop to save yourself some headache. Link: http://www.msi.com/faq/nb-991.html

But in case it proves worthwhile, make sure all your drivers are at least as new as the versions available on MSI’s site (especially the Intel Rapid Storage driver): http://www.msi.com/support/workstation/WT60-2OJ.html#down-driver&Win7 64 (I’m not sure if that’s your specific model, but…)


#3

Thanks for the quick response. I’ve tried your links - replaced the ODD firmware and updated the drivers, but to no avail. I think I’ll give up now and return it to the vendor.