Slow R/W with Slackware

vbimport

#1

I have a box with a Lite-on DVD±RW bruner on it. The drive has worded well for burning CDs and DVDs, as well as for reading. Several months ago I upgraded from Slackware 10.2 to Slackware 11, and it is using the 2.4.33.3 kernel.

The drive is hdb, and the ide-scsi transpation goes to /dev/sr0-> /dev/cdrom

DMA is turned on.

When reading and writing I get VERY VERY slow IO.

The drive being used worked just fine under the older OS install, so I’m trying to figure out what may have gone wrong. I just noticed this because I generally only burn DVDs seasonally, and I do backups on a different machine.

Can anyone point me to a checklist I can run through to verify everything, so that I can find what might be wrong and resolve it?

Oh, running hdparm -T, gets “read() hit ROF - device too small”

hdparm -i shows pio0-4, DMA mdma0-2, udma0-4, and that the drive conforms to ATA/ATAPI-5

Thanks.

The Bird


#2

Welcome to the forum :slight_smile:

This issue is typical of a disabled DMA.

Sorry for my total ignorance in linux stuff, but I have no idea how to check DMA in linux (and I have no idea about the meaning of “hdparm -i shows pio0-4, DMA mdma0-2, udma0-4”). That drive should run in UDMA4 mode.

I have a laptop that I use to play with Linux, trying to understand some basic things (currently I’m playing with Fedora 8), and I noticed that after updating to latest kernel available in repositories, the network card is always disabled by default and I’m not able to enable it by default (I must enable it manually every time I run the laptop). I wonder if the same happened with DMA in your computer after you upgraded Slackware, i.e. the DMA was disabled by default and must be enabled manually in some way.


#3

I agree that it sounds like DMA isn’t working. The first thing I’d do is run hdparm, which I did, and it shows that DMA is turned on. I also looked at dmesg, and found that DMA was turned on at boot, and that the right driver configurations were used.

Anyone seen this problem with Slackware?


#4

/dev/hdb indicates the Slave drive on your Primary IDE channel. Are you sure this is your burner? It shouldn’t show both as hdb (IDE) and sr0 (IDE-SCSI) I think. And it’s not on the same IDE channel as your hard drive is it, cause that’ll always make it slow.

It sounds like something may have gone wrong with the upgrade, a clean install is always preferred (made easier if /home has its own partition, so you can format only the root partition and retain most of your settings).


#5

you’re not using K3B are you? If so update to the latest version, an older version of it (that would coincide with the release of slackware 11) had that exact problem, the drive was fine but start K3B and it sent the drive out of DMA mode.


#6

Using cdrecord for cds, and growisofs for dvds.

For reading, there are several ways I’ve tested…

One is:

time dd if=/dev/cdrom of=/dev/null bs=5120

It’s pretty slow.