Slow performance with SOHC-5232K

vbimport

#1

Will v2.4.0 remove the riplock and allow me to read new DVDs faster? I like to rip with my liteon 5232k and burn on my DVD burner to save wear and tear, but the ripping speed is half that of my burner.


#2

you can increase the readspeed with omnipatcher.


#3

How do I do this. I downloaded and flashed the firmware 5232k NKOJ, then Omnipatcher and rebooted. When I start omni, I try to load from drive ID, if I go to the Omni file, I get a message, Unable to Process this EXE.file, make sure the file is valid and unscrambled. If I go to the drive, it asks me to load a disc. Either way, I’m stuck. Same thing when I go to General Patches. What am I missing here?


#4

There should be a Readme file in the archive that contained OmniPatcher.
I don’t have the newest version, but all previous versions had one, which contained instructions.


#5

*Agrees with Chuck44 :iagree: *

ricoman, make sure you use the below firmware, on our site, as it needs to be unscramble firmware, which Liteon’s firmware isn’t:
http://codeguys.rpc1.com/firmwares/combo/stock/5232K.NK07-NK0A-NK0E-NK0G-NK0H-NK0J.stock.rar

make your changes and then flash the saved file to the drive. Omnipatcher only works with unscrambled firmware files, not directly to the drive ;).


#6

This is the only read me file (fast read patch), but it doesn’t tell me anything.:

Q: What happened to the patched firmwares that enabled faster read speeds for
recordable and rewritable DVD media on LiteOn-based DVD-ROM/CD-RW combo drives?

A: Because it was getting tedious for me to manually patch the firmwares and
because manual patching did not allow much flexibility in what speeds can be
used, I will no longer release pre-patched combo firmwares. But there is
something better! Starting with version 2.4.0, OmniPatcher can patch the DVD
read speeds for combo drives! Not only will there no longer be a wait for a
patched firmware to be released, but you are now no longer limited to just three
speed options, as OmniPatcher will allow you to fully customize the speeds that
you want to use.

Download OmniPatcher: http://codeguys.rpc1.org/patchers.html

The firmwares provided in this package are unscrambled and can thus be used with
with OmniPatcher. Please see the OmniPatcher documentation for more details and
for usage instructions.

Codeking: Did what you said, it’s the same thing I tried before with the same results and message. - Unable to Process this EXE.file, make sure the file is valid and unscrambled. If I go to the drive, it asks me to load a disc. :confused: Am I doing something wrong? When I check the drive, it shows the new firmware NKOJ but Omnipatcher won’t load anything.


#7

I meant the Readme.htm file that comes with OmniPatcher.


#8

I didn’t get any htm file with omni. Do you mean documentation page of the Codeguys site? I read it several times. I open omnipatcher, when I click load I get the omnipatcher folder, when I click that I get that message. If I go to the drive, I’m asked to insert a disc. Either way it’s looking for a bin. or exe. file. That’s it!


#9

Here’s a direct link to the Readme file:
http://codeguys.rpc1.org/docs/omnipatcher_readme.html


#10

thanks to Chuck44 I finally was able to access Omnipatcher. However after changing the read speeds and reflashing, there was no change in the rip speed, which is the main reason I tried it. I’ll try it again with another DVD later. Do I have to reflash every time? I remember when I had my old liteon 811S, you had to reset the write strategy each time for each media type.


#11

Maybe you did something wrong. After changing the read speed, you have to save the changed firmware and to flash this changed file. You only have to flash it once.


#12

That is exactly what I did. :confused: Though I still might be doing something wrong! :slight_smile: Or maybe the patch doesn’t work with the 5232K, in the past you could not patch combo drives. Has anyone had luck increasing the read/rip speed on the liteon 5232k?


#13

Well, the patching method did change, and the old firmwares that were patched by hand are patched differently than the firmwares patched by OmniPatcher, so there is a chance that maybe I screwed up somewhere and the new patching method doesn’t work. But since nobody else has reported any problems yet and because this new patching method has been verified to work on a number of other drive models, this seems very unlikely. But let’s be absolutely sure…

1/ After flashing your drive with the patched firmware, use LtnFW to dump the firmware from your drive and then load this dumped firmware into OmniPatcher. Look in the general patches tab, and it should report the patched speeds. This will verify that the firmware flash proceeded without problem.

2/ Run a full CD-DVD Speed test. This will show a transfer rate graph as well as the burst rate. Post the results of this test, please.


#14

Code, have checked this and all is working fine for me


#15

I have a 5232K and it works fine on my drive, my drive is one of the early ones with a seperate eeprom so I don’t know if that makes a difference?


#16

NOEEPROM has no effect on the patch. Thanks for the confirmations. :wink: So the problem in ricoman’s case is unrelated to the patch. Perhaps DMA isn’t on. Or something else is astray…


#17
  1. LtnFW only gives you 4 choices: checksum, compare, backup & update. Which do I use to dump my fw? I’m not a newb, I’ve dumped and flashed my NEC dozens of times, I’m just unfamiliar with the litey process. For the record, when I open patcher and check my settings, it does show that it save my settings (DVD9-ROM to 16x)

  2. Should I do the transfer rate test from my burner (ND-3500) or from the reader (litey 5232k w/patch)?


#18

Iceberg and PumaUK: When you say that you had no problems, do you mean that you increased your read spead of DVD9-ROMs? That’s what I want to do. The flash process was successful, but the read speed didn’t change.


#19

mine has, when loading the firmware which was ran through omnipatcher back again after creating a bin file, i have DVDROM/9 at 16x and DVD±/R9 at 8x , which are the settings i inputted


#20

What ever I set the read speeds to and then save the updated firmware and flash the drive with the updated firmware are the speeds I get, it all works just fine for me.