Slow EAC with LiteOn drives (SMART-X) (merged thread)

Hello, I have been a long-time reader of CDFreaks, but I have seldom posted.

I have a LiteOn 812S that I cross-flashed to 832S CG4E thanks to Codeguys’ excellent work.

I really like this drive. It, however, has a problem. Besides DVD backup, I use this drive as my main audio-ripping device. I use, as a lot of people around here, Exact Audio Copy. The problem is that this drive has a “spin up” problem with EAC. It does not reach full speed until 11 seconds, 33 frames on burst mode extraction. Using EAC’s secure mode, IT NEVER spins up to full speed, giving crappy 2.5X ripping speed. Burst speed is 30X. “Real” secure mode speed should be something in between.
EAC’s developer, Andre Whiethoff has suggested that this could be fixed by firmware.

I kindly ask Codeguys to take some time to look into this. It would be cool, but I am still very happy using EAC’s burst mode with Test & Copy, it is just that sometimes it is not enough for some faulty discs. And only secure mode takes full advantage of this drive’s error correction.

BTW, this problem is common to all 2s drives.

Thank you very much.

It’s common to all LiteOn drives, I believe. Funny you should post this, as I’m currently in the process of ripping all 200 or so of my audio CDs into MP3s so that I could finally abandon the outdated CD format. :bigsmile:

Some of the rips go fast. But some of the rips go terribly slow, which is annoying. I put a disc into my LTC-48161H, and half the it, the drive’s reported max read speed is 48x max, and the other half, it recognizes as 24x. (for my laptop, it’s 24x/12x) Same disc, same drive, just eject and reload. I’m not sure what exactly the problem is, but I’m guessing that it might have something to do with SMART-X… just a guess. Not sure if that’s the case, and if so, how to go about disabling it… I’m better at writing patchers than actually finding stuff like that. :sad:

Having said that, 2.4x seems a little too slow. I get that speed, but that’s also because I use the LAME DLL and am encoding as I’m ripping, which kills the speed even more (“slow” rips are 2-3x, “fast” rips are 4-5x on my system because of the on-the-fly encode). If you are not encoding on the fly and are still getting 2.4x, that’s a little too slow. Check to see if DMA is turned on.

DMA is turned on. I am running my drive on an external enclosure and a laptop computer. It is a drive/app-specific problem, as I get 8X rips using DVDDecrypter and the mentioned 30X on EAC’s burst mode. I have resorted to rip all the tracks first using EAC’s burst mode with Test & Copy. It rips the same track twice, compares and if you get a matching CRC, the extracted data is secure. I can rip a CD in more or less 5 minutes like this. Very fast, indeed. But I would like to use EAC’s “Extract Image and Create Cue Sheet” feature, which I think is more convenient for ripping-encoding tasks.
Hope you can do something about it.

More info on this problem can be found here (it has some links)

When using Exact Audio Copy in new “secure” mode I can read at only 3.8X with my 1653S, regardless if ripping a song from the beginning or end of the cd. By turning of C2-capability in eac it drops to 2.5X.

In old secure mode I get upto 6.8X with buffer turned on, but 2.5X again with buffer turned off.

This all looks very disapointing considering that we talk about a 48X reader.

Even my 48X absolutely noname cheap cd-rom drive read at 8.8X to 15X in new secure mode. My Plextor 48/24/48a also read much quicker, too.

Turning on “spin-up” does not help at all.

Is there any firmware fix, driver-issues, or EAC alternative?

DMA on? Chipset drivers up to date?

Yep! :slight_smile:

You can select different “Drive Read Command” to see whether the situation improves

I found a solution to the problem, though not a perfect one! :slight_smile:

Actually I suspect Smart-X to be the source of the problem, but fortunately you can fool it to behave differently.

First of all I found out that the 1653S spins at only 8X when using EAC regardless in all modes beside BURST mode (I come to that one later)! It doesn’t matter whatever settings you use, it will keep spinning at 8X.

Yes that means, that it spins slower when you read the outer tracks of a CD. It also means that manually setting the speed to anything above 8X has absolutely no effect when using EAC.

Now the solution: Use BURST-mode at least once! From that moment on the drive will spin up to full speed in any EAC mode you use and prefer until you reboot your Windows!

You can even cancel the BURST-extraction, since the only thing that matters is that you start it once. That’s why I suspect SMART-X by the way. From that moment on you can chose any speed above and below 8X, the drive will work accordingly (until next reboot).

Does anyone know a way to turn off that Smart-X function?

Hi there! Does anyone know how to turn off Smart-X?

I have some strange EAC-related problem with it and suspect it to be buggy. :rolleyes:


get audiograbber. it’s freeware and has built in lame/ogg codecs.
for me it’s the best util for ripping audio cd’s.

Audiograbber is good, no question about it. And most of the time you would need nothing else. But, still, EAC has something no other ripper I know of has (when properly configured): accurate error reporting. EAC does not extract better than, say, Audiograbber, but WHEN IT CANNOT EXTRACT a piece of audio data, it does something that for me, is invaluable: it tells you.

This way, if the EAC log says that no error ocurred, you can pretty much rest in peace (and with a Lite-On drive, even more so). When you do what I do, which is buy CDs by the dozen, then rip them all and encode then and load then in my DAP, sometimes without having ever listened to them, so I can take on the road with me… what would you feel when you find out, away from home and from any possible solution that your tracks have pops and clicks? Sure a lot of people can deal with this. Not me.

That is why I cherish secure extraction so much.

Apparently this problem has no easy solution. Well, as I told before, EAC’s Burst mode AND Test & Copy is secure extraction, and with my drive, I can extract an average CD in 5 minutes.

Actually it seems like the speed-up from using burst once does not hold on until the next reboot, but only for a few minutes. But at least there is a way to get secure mode going fast.

I am doing some test if I can trust burst+copy/rest, seems quite good. Unfortunately you cannot use the option to read into leadin/out, cause it produces errors in both modes.

This problem started after US03 for the 812s, it did not happen on any lite-on firmware or drive before that. After that firmware, this bug appeared, and it’s still there even on the 1653s. I’ve emailed Lite-On about it and never received a reply. This is indeed a firmware bug, though. The drive just does not spin up fully when secure mode is used.