SLOW burns on Benq1670

I stopped using my I/O magic benq 1670 after I got a benq1655 from newegg about two months back. When I started using the 1670 recently, I noticed that the burns are EXTREMELY slow…I’m talking over TWO HOURS to burn and verify a regular SL dvd.

What I have tried:

  1. Checked to see if DMA is enabled. It looks like it is enabled…but I do have a concern. Under one of the primary channels, device 1 is selected as “DMA if available” but the current transfer mode shows “PIO mode” and it won’t let me change it. However, it doesn’t show this in the other primary channel. Sorry, I don’t quite understand this–I hope I’m making sense. I have included screenshots below.

  2. Tried burning using different burning software. Tried Nero Burning Rom 6 and ImgBurn. No difference in result.

  3. Upgrading to the newest 1.02 firmware (did this using MCSE, then upgraded using new 1.02 firmware, converting the I/O magic drive into a “real” benq 1670). RESULT: still took over two hours! Posted below is a log from a recent burn using Nero Burning Rom 6, Verbatim MCC002 burnt at 8x).

I hope I have given you all enough information to help me figure out what is wrong with this burner. :sad:

Also, here is the exact same file burnt with my benq 1655 (MCC02 at 8x).


Hi,

I would do this for troubleshooting:

  • use an 80 wired IDE cable
  • connect the 1670 jumpered as Master to the end connector of the cable
  • connect the 1655 jumpered as Slave to the middle connector of the cable
    See if that works.

Michael

Yes, PIO Mode is the culprit here. In addition to Michael’s suggestion, uninstall the IDE Channel with the two burners in Device Manager and reboot. It will be re-detected and installed by Windows. This could get rid of the PIO problem. If nothing helps, you can put the two drives on seperate IDE Channels (use two ribbon cables), so they can’t interfere with each other.

On compu’s with newest mobo’s windoze drivers won’t solve anything. You’ll have to install motherboard specific chipset (IDE) drivers. :wink:

I’m pretty sure I’m using an 80 wired IDE cable. The cable connects both benqs and doesn’t seem to be the problem (I’ve always used the same cable, even when the 1670 didn’t take 2 hours to burn).
If I change the 1670 to master and 1655 to slave, would it cause the 1655 to have the same problem (long burns…probably due to the PIO settings, which I can’t modify)?

Thanks, cressida. I will try uninstalling it from the device manager first and see if I can get it to not be in PIO mode. Then I’ll try Michael’s suggestion of switching the master/slave positions. Hopefully one of these would work. I’m actually not sure if I have another slot/cable in my computer (dell dimension E510) to connect the two burners separately… I’m pretty sure the motherboard doesn’t, since I had to remove my spare IDE drive in order to put in the 1655…

Okay, so I spent almost the whole day trying out different things…and I’m still stuck…
I tried uninstalling it from the device manager, rebooting and letting it reinstall…no difference.
I tried switching the master/slave positions…no difference.
Haha, I even tried setting them both as masters…and my comp had problems with that so my guess is that it doesn’t allow you to set both drives as masters.
I tried using three different IDE cables (all 80)…no difference (figured might as well try this to make sure it’s not a defective cable or anything).
I CAN’T try using two separate IDE cables for the drives cause (I think) my computer only has one IDE slot on the motherboard, and that only allows me to split it up into a max of two IDE devices :frowning:

How I checked to see if it was working properly (meaning it doesn’t take 2 hours of more to burn!): I burned a disk on both the master and the slave drives. The master drive allowed me to burn and verify the disk in about 12-16 mins (don’t remember the EXACT time…but somewhere around there…which I think is pretty long considering people here are getting about 8 mins/disk). However, the slave drive would ALWAYS take over two hours (this is why it took most of today).

I think the problem definately lies in the PIO mode that I’m not able to get out of for one of the primary IDE channel’s device 1. It is always selected as “DMA if available” but the current transfer mode stays as “PIO mode”.

I really don’t know what else to do. :frowning: Any other suggestions, please?? I’m thinking of calling dell to see what they can do…I mean they sell the E510 with two optical drives, so it must be able to function correctly, right? Even though the benqs aren’t from them, it should still work!!! So right now I can’t even take advantage of having two burners…

Hi,

Please run Nero Info Tool and post the screenshot of the “Configuration” tab.

I burned a disk on both the master and the slave drives. The master drive allowed me to burn and verify the disk in about 12-16 mins (don’t remember the EXACT time…but somewhere around there…which I think is pretty long considering people here are getting about 8 mins/disk).
12-16 min including verification time is good as this corresponds to 6-8 min of writing time.

I think the problem definately lies in the PIO mode that I’m not able to get out of for one of the primary IDE channel’s device 1. It is always selected as “DMA if available” but the current transfer mode stays as “PIO mode”.

I really don’t know what else to do. :frowning: Any other suggestions, please??
Please check BIOS setup if there are some DMA/UDMA settings you can adjust. These should all be set to “Auto”.

Michael

Delete your DVD drive in Device Manager and reboot the Computer. If this does not help delete your primary IDE controller in Device Mnager and reboot your computer. This mostly works. Don’t be afraid, after rebooting, your IDE controller will be installed through the PNP cycle.

I FINALLY got it to work! I tried everything, but michael-I finally did your suggestion of going into the BIOS and changing the setting. I wasn’t sure what I was doing, but I enabled something for one of the IDE channels that was set to off, and when I checked the device manager, it showed all the primary and secondary IDE channels as DMA. Thank you all so much for helping me to troubleshoot this problem.
I also tested my external burner (a liteon sohw-812s–>832) that I haven’t used in a while. I tested it with a cheap staples-branded CMC MAG 01 disk, and the burns were pretty bad. It also took a pretty long time…I would say over half an hour to burn and verify, and this was using imgburn to burn an .iso file. I was wondering if it usually takes over half an hour to burn/verify on external drives. Thanks!

Hi,

Fine to read that :).

I also tested my external burner (a liteon sohw-812s–>832) that I haven’t used in a while. I tested it with a cheap staples-branded CMC MAG 01 disk, and the burns were pretty bad. It also took a pretty long time…I would say over half an hour to burn and verify, and this was using imgburn to burn an .iso file. I was wondering if it usually takes over half an hour to burn/verify on external drives. Thanks!
This should be posted as a new thread in the Liteon section :wink:
Half an hour including verify equals to 4x (max) burning. If that is okay or not depends on the support of that media by your drive’s firmware (maybe unsupported media written with default strategy) and your USB interface. I am able to burn and read at 16x max with my USB connected Sony DW-G120A (=Liteon SHM-165P6S) and onboard USB controller (VIA).

Michael

i have same issue with my 1670 writer. Have checkd BIOS settings and all DMA settings are set at Automatic. Any tip on what settings i can/need further to adjust. Can you pls supply some more details how this problem was fixed? Tia

Best would be to provide a screenshot of the settings accessed in the device manager (like the one I provided in my first post with the screens showing the IDE primary and secondary channels. That would probably allow people here to see what’s going on.

Even @ 832S, that burner’s still not a 16x one, so I’d be surprised if it supports CMC MAG. M01 in the firmware (I’m guessing when you said “CMC MAG. 01” that you meant M01).

From the burn speed mentioned, it sounds like it’s using a default write strategy (probably around 4x). :slight_smile:

pls find attached some images

what surprises me is that of all IDE channels are mentioned 3 times. The primary and 2 out of 3 secondar controllers seem to be ok (transfer mode DMA if available and Current Transfer mode either blank or UDMA. Only the last secondary one seems to be causing the problem (current transfer mode set at PIO, despite setting transfer mode to DMA if available). I have delete all secondary ones and rebooted.

I have updated in BIOS the following to Auto:
Integrated peripherals
on chip ATA Devices
IDE primary Master PIO Auto
IDE primary Slave PIO Auto
IDE primary Master UDMA Auto
IDE primary Slave UDMA Auto
IDE secondary Master PIO Auto
IDE secondary Slave PIO Auto
IDE secondary Master UDMA Auto
IDE secondary Slave UDMA Auto

Hope this helps. Did I forget one of the BIOS Settings?

TIA

jheersch



You possibly have SATA controllers on your mobo too.
If you haven’t installed the drivers for your SATA controllers, they are running in compatibility mode, making them look like a bunch of IDE channels. In this case, performance is slowed down though.

kg_evilboy: Thank you for the tip. :bow: That was indeed the reason. Now it is working perfectly!