Silicon Image based Sata/IDE controllers that are flashable or not




[li]Rosewill RC-209, SATA RAID
[/li][li]6 SATA ports (up to 4 internal or 2 internal and 2 external devices)
[/li][li]SiI 3114
[/li][li]Holtek HT27C010-70, 1-Mb, NON-FLASHABLE
[/li][li]Not available any longer

I was considering getting that at one point but emailed Rosewill support to find out if it had a flash BIOS first. It didn’t so I didn’t. :wink:



[li] CompUSA-branded, PCI SATA (not RAID) SKU #329648; also shown on card is #p143512-2x3b
[/li][li] 4 SATA ports (up to 2 internal or 2 external devices, only 2 at a time)
[/li][li] SiI 3512
[/li][li] HOLTEK HT27C010 – CMOS 128Kx8-Bit OTP EPROM (write once, read-only) , [B]NON-FLASHABLE[/B]
[/li][li] Got it at CompUSA a few years ago, was $20-30, probably not available


great list! thanks


The “How to update Bios” link in first post of this thread no longer works. Does anybody know of an updated link that works?


[QUOTE=bevills1;2270658]The “How to update Bios” link in first post of this thread no longer works. Does anybody know of an updated link that works?[/QUOTE]This should work: (Took me one minute to find :smiley: )
PDF document:




[li]Syba SD-ATA133, IDE RAID and non-RAID
[/li][li]2 IDE ports (up to 4 devices)
[/li][li]SiI 680A
[/li][li]AMD AM29F010B, 1-Mb, flashable in DOS
[/li][li]Available at Newegg as RAID, $22.99 USD, or as non-RAID, $16.99 USD

According to the SiI website, this chip is flashable using their Windows flash utility. Can anyone confirm that?


The Syba link from the KTL post no longer works, but if it’s the same Syba adapter at, then it is flashable. I purchased one of them, and it flashed and worked without problem. I’ve also read other posts on CDFreaks where users have had good results with this card.


Hi,[QUOTE=Saucerful;2311246]According to the SiI website, this chip is flashable using their Windows flash utility. Can anyone confirm that?[/QUOTE]My personal experience with a 0680A card was, that I needed to flash from plain DOS. The Windows drivers for the Raid mode were too old and didn’t come with the GUI flash tool built-in.



My flash was done from Windows to non RAID, IDE mode on an old Dell 4550 without RAID, and there were no issues. I have no experience flashing to RAID mode for which DOS flash may be needed.


It was just the other way round with my card, which came as Raid.
After having installed latest Raid drivers (running W2k here), there was still no “Flash” tab in the properties of the driver. And if I remember correctly, there wasn’t the SiI applet in Control Panel either.
So I had to use the DOS tool to flash my card from Raid to non-Raid.


The SiFlashTool.exe supports the following Silicon Image, Inc. controllers.
[B]SiI 0680
SiI 3x12
SiI 3114
SiI 3124
SiI 3132 [/B]

  SiFlashTool .exe supports the following flash memory chips:
·	[B]AMD Am29F010B
·	AMD Am29LV010B
·	AMD Am29LV040B
·	AMD Am29LV400BB
·	AMD Am29LV400BT
·	Atmel AT29LV010A
·	Atmel AT49BV512
·	Macronix MX29LV004B
·	Macronix MX29LV004T
·	Macronix MX29LV040
·	Macronix MX29LV400B
·	Macronix MX29LV400T
·	Sanyo LE28C1001D
·	SST 39SF010
·	SST 39SF020
·	SST 39VF010
·	SST 39VF020
·	ST Micro M29F010B
·	ST Micro M29W040B
·	ST Micro M29W400DB
·	ST Micro M29W400DT
·	Winbond W29C011A
·	Winbond W29EE512[/B]

Procedures to run SiFlashTool .exe
·	Open Windows command prompt
·	Change to a directory where the SiFlashTool .exe and BIOS binary file are located.
·	Run SiFlashTool to update the flash memory with BIOS binary code

The SiFlashTool.exe command line syntax is as follows:

SiFlashTool [/BusNum:xx /DevNum:xx] [/File:filespec] [/v]

BusNum / DevNum: These parameters specify the PCI bus and device number respectively of a Silicon Image storage controller. These parameters only need to be used if there is more than one Silicon Image storage controller in the system.
File:  This parameter specifies the path and name of the BIOS image file to be programmed.
/V: This switch causes the program to only display the version number of a controller's BIOS.  No BIOS image is programmed when this switch is used.  The /File parameter is ignored if specified along with this switch.  If /BusNum and/or /Devnum are specified, then only the BIOS versions of controller's at the specified PCI locations are displayed.

The following list identifies SiFlashTool.exe return codes noted when the program exits.
·	0 	– BIOS update succeeded. SiFlashTool successfully confirmed a match between the bin file and resulting FLASH contents.
·	1	 – Invalid parameter value specified.
·	2	 – Unrecognized parameter specified.
·	3 	– SiFlashTool does not support the implemented FLASH chip.
·	4 	– Silicon Image controller not found.
·	5 	– BIOS image file was not found.
·	6 	– Error encountered while reading the BIOS image file.
·	7 	– Image file is too large for the implemented FLASH ship. Download was aborted.
·	8 	– Failed to perform FLASH chip erase before writing the BIOS to the FLASH chip.
·	9 	– Failed to perform a FLASHchip write.
·	10 	– After writing BIOS to the FLASH chip, failed to verify FLASH chip contents to the BIN file.
·	11 	– Incorrect controller selected

This from SiI document that came with my latest SiL0680 bios.
[B]Note[/B], SiFlash is a command line tool. Not sure if a GUI version exists. :slight_smile:


I have a Bytecc SiI3512 PCI card.

This card came with the SATARaid BIOS, and
it uses the EN29LV040A flash memory.

I see in an earlier post (#2 by KTL) that this
device is flashable in DOS. But when I try, the
flash utility requests that I choose from a
list of flash chip parts.

Which one should I choose?

(I’m using the latest Silicon Image flash utility - UpdFlash ver3.36)


Which one should I choose?

Using updflash.exe select “Pm39LV040 4MB compatible” to flash via DOS.

My SIL3132 card uses the same flash chip.


Thanks for the reply, zhadoom.

So, do you think I should wait for other opinions? ; )
How did you decide to choose “Pm39LV040 4MB compatible”?


[QUOTE=LikelyNot;2488265]Thanks for the reply, zhadoom.

So, do you think I should wait for other opinions? ; )
How did you decide to choose “Pm39LV040 4MB compatible”?[/QUOTE]

After much research in forums and Google I could find a Russian forum with a user in the exact same situation. In my case SIL3132 + EN29LV040A . I used the PMC 4mbit option and it flash OK.


Thanks for the assistance, zhadoom.

I flashed the EN29LV040A by choosing the
option “Pm39LV040 4MB compatible”, and
three months on, my Bytecc SiI3512 PCI card
still seems to be functioning correctly.

Be warned that this Bytecc card has been sold
with at least three different flash chips over the
last couple of years, including a non-flashable
(one-time programmable) chip. So examine any
potential purchase closely if you hope to be able
to modify the firmware.




Syba SY-PEX40028, SATA RAID, low profile bracket
2 SATA ports (internal)
SiI 3132
SST 39SF010, 1-Mb, flashable in Windows and DOS
Available at Newegg, $19 USD

These ones should be similar, if not the same, but just different PCB and/or mounting bracket.
Syba SD-LP-PEX2IR (low profile bracket)
Syba PEX-40015
Syba SD-SA2PEX-21R



nice info! :flower:


I got this one from a E-bay seller and it’s flashable and seems to support opticals even in raid mode.

[B]SYBA SY-PCI40010 PCI[/B] Has the 3124 chipset in it by the way.

I’ve seen the exact same card on New Egg and amazon before too and it supports SATA 300 just in case you actually do want to put newer hard drives on it.
It was 39.09 shipped from Accstation and is around that price everywhere else except maybe no free shipping, depends on sellers mood.
Works in win7 though I had to use the Vista raid drivers to make mine happy even though 7 does have a raid driver that supposedly supports it. the 7 non raid driver installed fine when I flashed it over to try that side.
It would accept 2 burners mostly fine but when I added a third it had the yellow exclamation point and wouldn’t fully use the third drive and 7 wouldn’t shut down properly.
Finally I just hot plugged each drive one at a time and then it found and installed each one in turn and so far all 3 now work fine.
Here’s the link in case anyone wants to try one