SiI680 rev 2 card problems

vbimport

#1

Hello,

I’ve just upgraded my system with a new motherboard (Gigabyte GA-P35-DS3R), and since it only had one ide channel I bought a SiI680 IDE controller card (sold by Delock).

The card came with RAID bios, so I flashed it with the latest IDE bios and installed the drivers under Windows XP SP2.

I have two drives connected to it, a Nec 3500A and a Liteon 52246; I tried all possible combinations, setting them as master/slave, changing cables, plugging them into separate connectors, …

The problem that I have is that the drives are detected everytime in the BIOS, but they are randomly detected in Windows, sometimes both appear, sometimes just one, sometimes none.

What puzzles me most is that if I disable/enable the controller back, one or several times, once I see both drives detected, both work faultlessly, I have been able to burn CDs/DVDs and read them at full speed every time, so the controller seems to work properly in that area.

So the problem is that the drives don’t always get detected in Windows.

I’ve tried to move the card between PCI slots, tried several drivers, …, I’m out of ideas, and by the way, everything works properly under Slackware linux. I’m beginning to thing that this must be some kind of timeout issue (I can see PNP680 issuing “\Device\Scsi\Pnp6801” timeout events during boot.

I’m using the latest bios and drivers downloaded from the silicon image website.

Thanks for your time and help.


#2

Ok,

I already figured out and fixed the problem. It seems that it is a mix of the improper ATAPI Identify information reported by the Nec 3500 and the Silicon Image drivers that seem to reset the devices in a way that they block the controller.

So I did two things; I picked up the 2.1b firmware for the NEC and manually added extra data at offset 80 76 of the identify data block (I can’t remember exactly, but that data is missing from the original nec firmware, there are zeros). I fixed the checksum, flashed the drive and the card changed from recognizing the 3500A from Pre-Ata2 to ATAPI5.

Even then, I got the same problems of drives dissapearing at boot, so I tried with several drivers, and the only one that worked was the oldest one 1.0.0.12, with it I can read and burn at full speed with both drives and have found no issues.

So I would suggest to Silicon Image’s software engineers to take a look at their latest drivers and fix them (silicon image doesn’t offer support directly to end users).

By the way, I finally left the NEC as master and the liteon as slave on the first channel of the card.

Best regards.