Should I, Or Not? Firmware?

vbimport

#1

OK got my 5005 player today Manufactured 3/05. I used my D8 camcorder and it recorded great. My question is should I upgrade to the latest firmware? I do see some red tint in the video from my D8, and I thought the newest firmware fixed that. BUT after reading some of the posts it looks the the newest firmware could have some major bugs in it? Any suggestions? Thanks.

Firmware now is 103-010D.


#2

Ok just went to Liteon download page. There are two files to download, a drive firmware update (LFNA1000.E30.0102) and a system update (LFNA 1098.ES5.0102) Is the drive firmware update new? I dont remember seeing this one, i could be wrong?


#3

There are no confirmed reports of any major bugs with the newest firmware.

Where are you getting your firmware number from?


#4

Reading some post there seems to be a problem with the 1098 firmware that causes some disks not being able to be recognized.

I am getting my firmware number by going to setup on my remote and reading it from the top of the screen.

I am taking the plunge and will update the firmware and drive firmware.


#5

you serial number should look like xxxx-xxxx-xxxx-xxxx (xxx-xxxx numbers in parentheses) the third set of xxxx is your firmware. My US 5005 Sep '04 serial number is 0102 -1840-0098-g2bd and I have the latest firmware installed. The numbers in parentheses you do not have to enter at the liteon site to check for updates.


#6

The problem you mention has NOT been attributed to faulty firmware, at present people are trying to get together info to see if a pattern can be established.

I know many, many owners that are using the latest firmware with no adverse effects.


#7

I have updated my “machine firmware” to 1098 right after it came out and have had only minor issues with disks. But, I have the older drive and did not have to do a “drive firmware” update. I would be more cautious about doing the drive firmware update than the machine firmware update. There is a large user base utilizing 1098 successfully. We do not know for certain the differences between the machines having the disk reading/finalization problems and the ones that don’t. We do know that there are at least two or three drive models at play; some with firmware updates and some without. Based on this I would be careful about drive FW updates until some clarity emerges on this issue.

It is entirely possible that the drive FW has nothing to do with the problem. The truth is we don’t know and Liteon has not provided any clear information. There are too many users though having the problem with varying media types to blame it on the user or the media.

That’s my 2 cents worth and that’s about all it’s worth.


#8

I wouldn’t try to flash the firmware using the cheap LiteOn DVD player in the recorder because if it fails you can be left with a door stop! I had to use an NEC ND-2510A to get it to work after it failed with the built-in drive.


#9

Just got mine and its a 0120-1840-0098-b20a FW with a March manufacturer date. I am a little gun shy also on the two flash sequence since it works!
ArizonaSteve///How do you use you computer drive to flash the 5005 :confused:

Funny that the serial number on the back of the unit is different than the menu screen.


#10

The same way I did in my 5007, just connect it in place of the original one.


#11

Nice to know info!


#12

mjckjc ! What did you do?
Mine is working and it looks like it came with 0098FW! So if its working, should we break it LOL

PS/ Do you make two separate flash disks! One for the systemFW and the other for the drive FW?


#13

I caved in and updated. So far no problems. Transfer from a Sony D8 camcorder going good.

I put both updates on their own separate disks. Both went on fine.


#14

ok! I guess i will try it! famous last words!


#15

Ok I burned the files 3 times on different disks and it loads and says data disk but no menu to flash! :confused:


#16

etp: I had the same problem at first. I use Nero to burn.

  1. Unzip files.
  2. Open Nero
    3.Make CD ISO file<Start Multisession disk<New
  3. Find the file you downloaded on right pane and drag the file over, NOT THE FOLDER, BUT THE FILE ITSELF.
  4. Go to burn, and make sure write box is checked.
  5. When completed put CD in 5005 and a menu will appear and ask if you want to upgrade your firmware?

I had the same problem you had because I was using no multisession.

Sitting here thinking more I am almost sure I used Multisession? If that does not work check no mutisession?

Like I said I had the same problem you had Data disk would show up on the screen and nothing would happen. After I did the above everything worked fine. Make sure you put both files on different CD’s.


#17

The disks were fine! Evidently you need to reset in the setup menu and shtdown with the disk in the tray and turn it back on. Once the system updated the drive fw flash worked as advertised. Liteon instructions were bad to say the least.


#18

This is a common situation with FW disks. In addition to resetting to factory defaults, sometimes turning off the power and restarting the machine with the CD in the drive also works around the “data disk” issue.


#19

The last time I tried to hack the firmware it would not recognixe the f/w disk, I turned it off and waited a few minutes each time and it did not work. I did not woant to wait overnight like the last time it worked for me so I finally did a restore to defaults with the f/w cd in and when it went to start up again it read the f/w cd fine. Crazy 5XXX’s :slight_smile:


#20

Did my first DVD+R maxell002 last night! Perfect!

Question! Is there any DVD recorder that uses componant in for Higher quality video and actually works?