Should I flash the firmware on my DRX-810UL?

vbimport

#1

My Sony DRX-810UL, which is only a couple of weeks old, decided not to burn CDs today. (KEY_MEDIUM_ERROR 030C00)

Should I try flashing the firmware? How do I figure out what the current firmware version is?

And when I checked the Sony website, I found two firmware updates: version 2.0d and 2.0e. I assume I want the 2.0e, right? It’s dated March 06 (the other one I think is dated November 05).

TIA.


#2

Hi! Your current firmware is usually shown next to the selected drive’s name by most burning apps. Try running Nero Toolkit -> InfoTool or CD-DVD Speed if you can’t see it anywhere else.

Installing 2.0e would be good, but firmware updates these days are mostly geared towards improved DVD performance and probably won’t change CD support. I still think the drive just doesn’t like those TY CD’s you have.

Hopefully someone else will jump in for a second opinion :slight_smile: .


#3

Thanks – Nero’s InfoTool tells me the firmware is 2.0d, so there IS a newer version available.

I ran another CD test using a TDK blank, and it also bombed with the exact same error (key medium error, same code). I think the TDK is a Ritek:

11:09:34 AM #9 Text 0 File DlgWaitCD.cpp, Line 2433
Recorder: SONY DVD RW DRU-810A;
CDR code: 00 97 15 17; OSJ entry from: Ritek Co.
ATIP Data:
Special Info [hex] 1: C0 00 90, 2: 61 0F 11 (LI 97:15.17), 3: 4F 3B 46 (LO 79:59.70)
Additional Info [hex] 1: 00 00 00 (invalid), 2: 00 00 00 (invalid), 3: 00 00 00 (invalid)

Here’s the corresponding info from the Maxell, which I assume confirms they are Taiyo:

4:54:00 PM #9 Text 0 File DlgWaitCD.cpp, Line 2433
Recorder: SONY DVD RW DRU-810A;
CDR code: 00 97 24 01; OSJ entry from: Taiyo Yuden Company Limited
ATIP Data:
Special Info [hex] 1: C0 40 98, 2: 61 18 01 (LI 97:24.01), 3: 4F 3B 49 (LO 79:59.73)
Additional Info [hex] 1: 00 00 00 (invalid), 2: 00 00 00 (invalid), 3: 00 00 00 (invalid)

I’ll poke around and see what other blanks I have (I’ve still got a few Fujifilms that are also Taiyo), but if the drive doesn’t like Taiyo or Ritek, I’m not sure I like the drive! <LOL>

Could it hurt anything to try the firmware flash? Should I call Sony tech support first?

Stupid question – I’m not knowledgeable about all this technical stuff – could the ASPI layer have anything to do with the problem, or does that only apply to SCSI devices? (My hard drives are SCSI, except for one.) You can tell I’ve been Googling the problem, and clutching at straws …


#4

I see it fails on the Ritek as well, not good… Nero uses its own aspi-driver, normally there’s no need to install adaptec’s. I would update the firmware to 2.0e though, this should not impair your warranty.

Also, have you updated your Nero recently? Version no. 6.6.0.18 would be good to have. There’s a download link (the second works) in this recent thread. Just run the executable [I]Nero-6.6.0.18_no_yt.exe[/I] and it will update your installation (even if it’s an OEM version you have).

Since it’s an external drive, the easiest way to exclude problems with your system will be to attach it to another PC and test. It could be a USB-problem too. Do you attach it to one of the mainboard’s USB-ports or via a PCI USB2-card?

Just some thoughts. Anyone else?


#5

I updated the firmware, rebooted, and burned a perfect CD (one of my Maxells). So, once again, I am cautiously optimistic. I’ll burn more CDs in the next couple of days and see if I stay lucky.

If not, I’ll update Nero (I got the full retail version of 6, and I’m at 6.6.0.14 now) and/or try hooking up the burner to my laptop (I can’t believe I didn’t think of that!). I attach the burner via Firewire to my desktop PC – haven’t tried it via USB yet. I’ve read a lot of arguments about which is better – FW or USB – but I don’t know which is supposed to be the clear winner. (I’m not concerned about speed, only about burning successful disks). FWIW, I’ve got the old FW 400, not the new faster one.

Anyway, it would be very easy to hook up the burner to the laptop, so I can try that next if I get another burn failure.