SHM-165P6S Woes

vbimport

#1

I recently have come back home from college and was told by my family to fix their computer (being an Information Technology major, I of course have to repair everything when I get home).

Anyway, their DVD drive, for some crazy reason, was not reading any DVDs or CDs, so I attempted to uninstall and reinstall it, with no luck.

I figured that I miht have to upgrade the firmware or drivers. I noticed that it only used the default Windows driver, so I continued to go onto updating the firmware. I attempted to update to the MS0M version of firmware, but It spit out the wonderful error “Unable to flash firmware. Please contact with your vendor !” (Wonderful Engrish)

I then tried to upgrade with the MS0N firmware; this processes seemed successful at first, with it processing and reaching 100%; then the program stopped responding and crashed (wonderful). I figured the drive is basically dead firmware-wise, although it still displays the firmware version as being MS0C, the default that the drive came with.

Ever since then, I have been trying to re-flash the drive with various firmware, completely unsuccessful with each try. I’ve attempted to use LtnFW and EEPROM_Utility, both failing in helping me restore the drive.

Any help in this matter would be greatly appreciated!


#2

Hi,

if the drive had worked before, then there is an issue, that cannot be cured by applying some firmware update.
I suspect either a dead drive or something has messed up the Windows installation. to sort out the latter, get a Knoppx or Kanotix CD and try to run that on the system. In addition you may try the drive in another system.

Michael


#3

Let’s focus on getting your drive upgraded first. You cant us LtnFW or the EU tools to flash your drive. The only tool that can be used is XSF and this must be used at real DOS (boot floppy) and you will have to use a 2MB bin file of the firmware. But this is a last resort only if the drive is not detected by windows.

1/ Is the drive now recognized by Windows?
2/ Does the system have NForce IDE drivers installed?
3/ Does the system have ASPI installed (NeroInfotool will tell you this)?


#4
  1. Yes, Windows recognizes the drive, but it is unusable.
  2. Yes, the nForce IDE drivers are installed.
  3. No, ASPI is not installed (according to NeroInfoTool).

Also, what command would I use for XFS?
The drive is on the Primary Master IDE channel, as I have the machine configured with a RAID 0 SATA setup.

Thanks again for your help.


#5

I apologize for a double-post, but I’ve somewhat solved my problem.

I booted into DOS and flashed my drive using XFS - it worked :smiley:
I then booted back into Windows and attempted to read another CD - it failed again.
For just a hunch, I tried disabling DMA for the IDE Primary Master drive and behold, the drive started reading the disks again.

Of course, I don’t really enjoy keeping my drive in PIO mode, so is there anyway to re-enable DMA? I’ve attempted uninstalling and reinstalling all of the IDE Channels and the drive itself with no success.

Note: The firmware I flashed it to was MS0M, so I could attempt flashing it to MS0N.


#6

It may be the NForce drivers giving you problems. Install the standard MS drivers and try the drive again.

To reinstall them, right click the NForce IDE controler in Device Manager => Properties => Driver tab => Update Driver => Install from list or spacific location => Don’t search => Standard Dual Channel IDE Controler.

Reboot and see if the device is now working.

Edit: I would use MSON, as the MSOM firmware can have issues with dash (-) media. :iagree: