SH-S203B - Sil3132 Boot Problems?

Hi all,

I have just replaced my old NEC 3520A with a nice new SH-S203B but if it is connected to my Sil3132 PCI-e card at boot I cannot boot at all? It just sits on a flashing cursor. I can boot fine when it is connected to the m/b sata but the m/b sata is fried (hence the pci-e card) so it is unusable.

Any ideas?

I have checked and triple checked the bios settings, everything is fine…

Anyone else used the Sil3132 with any other SATA DVD-RW attached?

Thanks in advance, need to get this sorted!

Hi and Welcome!

operating an optical drive on PCI(e) controllers isn’t easy at all as there are many controllers that have problems with ODD. You might have a look at the big IDE controllers thread.
Some more generic hints:
At first, make sure your card is bootable at all. Also, check wether there is a BIOS setting “boot from SCSI” or similar. Another thing to check out: the SATA card must not be set to any RAID mode.

Michael

Welcome to CDF’s

Do you have a link to the pci card you bought?

thanks for the quick replies. I’ve actually managed to solve the problem now… although im still not sure why the original problem occurred.

the card is definitely bootable as my system hd is sata and boots of the card. it was just when the drive was connected i could not boot.

here is the card…

http://www.siliconimage.com/products/product.aspx?id=32

The problem was solved by booting up the system as normal with my case open, i then attached the sata connection as it is hot-plugable. windows saw the drive as normal. i updated the firmware although the version i ‘updated’ too was apparently the same anyway. i then restarted and problem solved!

i still have no reason as to why i had to attach the drive while windows was runnning.

i shall see if i can boot off a windows cd using it and let you know what happens.

it seems the problem has returned… i must have got lucky the first time with my method!

any ideas what this might be? i assume its a card firmware issue rather than something to do with the drives firmware.

Well.

Do you look at the configuration page of the card ? boot sequence or optical support ?

Other hint: Many cards doesn’t support optical devices if it’s at RAID mode ( even with just one disk ). Changing to sata mode maybe solve your problem.

Make sure you use BASE drivers provided by your controller card manufacturer or SiliconImage, (link for XP/win2k).

Avoid messing with RAID configuration utility, (as already mentioned by [I]zhadoom[/I] and [I]mciahel[/I]).

You might want to check out this thread.

i am using the latest base bios. the drive shows up in my system bios fine, it just will not boot with it connected. ive tried a number of different startup sequences and it makes no difference. somethings definately a miss…

it works fine when attached to the pci-e card after boot. i’ve burnt dvd’s at 18x speed and verified them no problem. the sata bus is bust on the mobo so the card i have is the only option. this is really annoying, i would have stuck with the old drive if i knew it wouldnt boot with odd support!

Did you have a look at the thread i posted in post #8?

Hi :slight_smile:
Welcome onboard domb. :iagree: :clap:
If using ODDs’ with Sil SATA PCI cards then the trouble free way is to flash the bios to the latest Base Bios. (Note you must select Base & not Raid Bios).
Then update driver to to the one for CDRW/DVDRW (Note this will say it’s for 3112*).
But the Base Bios should let you use the drivers.(Make sure you choose the right OS & version[32/64 bit]).
My card is 3512 using Base Bios (non-raid) & drivers for Vista 32 bit (3112).
Basically these drivers are 312 etc.

Thanks zebadee for explaining this procedure in details. :clap:
I failed on that in my post above. :sad:

Also, nice to see we still have a few members here knowing what they are talking about and not only posting for the sake of posting… :wink:

Got the same problem here. All my sata ports of the mobo are used by harddisks so I decided to order a sil3112 pcie controller for my 203. The package arrived today in the morning when
I had to work, so I have to take it from the post office tommorow.
Then I will show you my experiences of installing.
I first contacted the manufacturer of the card and asked if the controller is able to handle ODDs. They answered me exactly the same as zebadee did.
"Flash it with the standard non-raid bios, install the non-raid driver and it will work"
The bios and drivers are already downloaded. Its version 7405 for the bios and 1.0.14.1
for the driver.
We will see tommorrow what happens…

Here I am again domb!
Just installed this nice little PCIe SATA card, with SIL3132 controller chip.
It came out of the box with raid bios installed, so I flashed the basic bios 7405, restarted my machine and installed the non-raid driver version 1.0.14.1.
Turned off the computer, attached my samsung203 and started again.
Everything went flawless, no hanging, no other problems.
I´m using a MSI mobo P6N-SLI Platinum with nforce 650i chipset, latest bios.
All HDDs are attached to the nforce controller, the Samsung is the only device attached to the SIL.
I just burned a DVD and scanned it with my LiteOn.
These MoserBaerIndia media is one of the 20x rated by Samsung, but with 20x burned I got horrible results.
This one was burned at 16x, but I thing they have to improve burning quality with thenext firmware.


Here I am again.
Since yesterday I rebooted and started my machine several times. Used Nero,
ONES and ImgBurn without any troubles. SIL3132 and Samsung203 works fine.
The attached screenshots of my computer shows what devicemanager says.
Maybe you flashed not the right bios or installed not the right non-raid drivers,
cause the download package includes the hole bunch for every OS.
You have to flash the “b7405.bin” and the right driver depending of your OS, XP
or Vista, 32 or 64bit.




hi all,

i have the same bios as gonzos-revenge and i have even tried older versions. i realise there are raid versions, oem versions etc. not sure what the problem is but i have resorted to using the mobo bios even tho it is faulty. i still seem to be able to burn off it. i had major problems with all the hd’s i used off the mobo sata which is why i am trying to avoid using it. cheers for the help anyway. must just be a combo of, mobo, sata card and drive choice… i’ve tried everything i can think of and others…

edit 1

seems i cant verify off the drive as it is throwing errors up off the mobo bus.

very annoying!

nobody had similar problems with this drive and a similar card? I can’t believe its just me. I have an ASRock 939s56 mobo with the latest firmware so i’m guessing it must be something with this as gonzo seems to be using the same card with no boot problems and the only difference is the mobo.

this is the actual card i am using…

http://www.syba.com/product/43/02/06/index.html

problem finally solved! all i did was reset the motherboard bios to default settings! i have no idea why this made a difference as I have set everything back to as it was before I reset and all is still fine. i recommend trying this to anyone having any problems!

:cool: happy burning.