SG-1 season 9 disc 4 menu problem

vbimport

#1

I recently purchased ‘Stargate SG-1 The complete Series’ seasons 1 - 10 from Amazon.

Its a box-set containing 2 ‘books’ and an episode booklet; each ‘book’ has 27 discs in individual cardboard pockets (3 pockets per page). Discs are region1, I’m in region 4 (Australia) and my Philips DVD player (DVP5900/98) has no probs playing region 1 discs, nor do my Pioneer and LG burners.

Some of the discs had scratches on them, but nearly all discs played without fault. I made a complaint to Amazon re scratches and they shipped a second set; but the replacement set looked like someone had been skating on sandpaper with them, so they are going back to Amazon.

Regardless of the scratches; I managed to use AnyDVD to rip all 54 discs to a spare 500GB WD sata drive; figured that was a safe way of backing up the whole set in addition to the original set I received and am keeping.

Problem with SG-1 season 9 disc 4
after loading the disc into player, it goes through the normal load screens etc and eventually gets to the menu ‘episodes’ and ‘features’ (is this root or title menu?).

I select ‘episodes’, which then briefly displays a menu list of the 4 episodes, then before I can do anything, it goes back to the DVD player screen as though the disc has been stopped.

This identical problem occurs on the same disc in the second set of discs. The discs from both sets work fine on my PC’s; select episodes with mouse, then choose the one to watch and all play fine - but not in the DVD palyer.

So I figure there maybe a problem with the menu itself; can this be fixed so I can create a new disc which will then work in DVD player?

Johnno


#2

I have the complete set and do not have that problem I for one would ask them to send another copy. You could also rent a copy form nexflex or one of the rental companies and see if the season nine disk 4 works in your player. I would then say change it with the one from the rental company but they would not like that.:slight_smile:


#3

Hi Samlar,
Yeah I figured it’d be my luck to have the same disc from both sets have the same problem, and the episodes on it were the same ones as on a missing disc from the local video store - DOH

Anyhow, Amazon are reluctant to send a 3rd set lest it is faulty as well; can’t blame them cause the postage to Australia and back can soon remove any profit they make from the set. So I’m now seeking replacement discs from the manufacturer, gonna try anyway!

The US region 1 discs have each season spread over 5 discs; whereas the region 4 set in Australia are spread over 6 discs for the first 8 seasons, then over 5 discs for seasons 9 & 10 - result is some episodes are on different discs to the region 1 set - episodes are still the same order, just some are on different discs ??

What I’m wondering - is there some software that’ll let me re-build/fix the menu? then I can simply burn a new disc that works.


#4

Need some answers you say that you copied the disk to hard drive and they play ok on the computer but not on the dvd player. I am assuming that you are talking about playing the disk you got from amazon on both the computer and dvd player not a copy you made from the files you put on the hard drive.

have you tried burning a copy of the disk from the files on the hard drive and playing it on the dvd player? If so did it work? If you have not I would try this first.

I did some testing and the file on the disk I think that is causing your problem is VTS_02_0.VOB. Here is what I did to find the file that I think is causing the problem and a way to work around it.

I took and labeled to folders one 9disk3 and one 9disk4. I then started clicking on the vob files until I found the one that I thought had the menu in it. It only came up for a short time but I could see the menu, so I took the VTS_02_0.VOB file in the 9disk4 folder and renamed it to VTS_02_0.VOBaaa. I then copied the VTS_02_0.VOB
file from the 9disk2 folder to the 9disk4 folder. I then clicked on the VTS_TS.IfO file and let the movie start. I then saw the menu for disk 3 not disk 4. I could then pick the first episode which had the title for the one on disk 3 not four but when I clicked on it the first episode for disk four started. This leads to a simple fix if you do not mind the menu showing the wong title just move the VTS_02_0.VOB from disk three to a folder that has disk four files in it and burn it. I am assuming that the VTS_02_0.VOB file on your disk four is the problem since it has the menu but it could be on of the other VTS_02_ files. I would think that is the VTS_02_0.VOB but not sure.

You said that you used any dvd to rip it to the hard drive did you mena the anydvd ripper or did you use another program to copy it to the hard drive with anydvd running to remove the protection.


#5

Both the dvds worked fine in PC, the menu stayed there and allowed me to mouse click the episodes - in the DVD player, the menu disappeared before I could nav any of the episodes with remote.

I used anydvd’s ripper - set one disc had ‘cyclic redundency errors’ when trying to copy, but set 2 disc copied ok; I burned a copy from the copied files on PC and the copy had the same problem as the genuine discs in the dvd player.

I’ll look into what you suggested with VTS_02_0.VOB


#6

None of them seemed to make a difference, so I was up late surfing around and came across these DVD tools

They look like they will probably most fix DVD problems, but seem a little complex, so will have to read up on them in some detail before I tackle anything - still I have all the discs backed up to hard drive, so eventually I should be able to fix.

[B][U]PgcEdit[/U][/B] - ’ The Swiss Army Knife of DVD Editing’ - download standalone .exe , manual and plugins - PgcEdit is a DVD IFO and Menu editor designed to allow the modification of the navigation commands and parameters of an already authored DVD structure.
PgcEdit is also an excellent tool to learn how a DVD works, with his powerful Trace function.
Since v0.6.0, PgcEdit is also the first program able to burn a Double Layer DVD-Video on DL DVD+R or DL DVD-R, with an interactive interface (including a preview), to select the position of the layer break.
http://download.videohelp.com/r0lZ/pgcedit/

[B][U]ReJig[/U][/B] - ReJig is a Windows GUI based MPEG-2 transcoding utility using compressed domain transcoding(recompress MPEG2 to MPEG2). It also supports DVD9 to one DVDR transcoding and basic DVD Authoring and VOB demultiplexing.
ReJig http://www.videohelp.com/tools/ReJig

I’ve emailed them to you in a zip file attachment via ‘yousendit’ (about 4 MB)

Johnno


#7

Is this a still menu or motion menu you’re having problem with?

You may want to try DVDFab HD Decrypter, even RipIt4Me, to rip to see if it causes the same menu display problem.

If you still have the same menu display problem using the above 2 rippers, then, if you don’t mind, zip the menu VOB (VTS_0x_0.VOB, VIDEO_TS.VOB if there’s menu in it) and all the IFOs from the season 9 disc 4, post a link to download here, someone may be able to find out the cause.


#8

Hi Toaddub,
thanks for the suggestion

they are all still menu items for navigation (not animated)

Unfortunately the 2nd set is now in the mail on the way back to Amazon.com (I’ve kept the 1st set as that was far better condition than the 2nd set they sent as replacement)

AnyDVD previously ripped the s9d4 from 2nd set successfully, but couldn’t rip s9d4 from the 1st set.

However DVDfab HD ripper managed to rip from 1st set, but it took 1 hour 19 minutes to do so cause it had a lot of surface scratches on it (FYI - my PC is AMD 2.8Ghz dual core with 2 GB RAM, so that’s not the cause of slow rip).

Used CloneDVD2 to burn a copy, but it still has the same menu problem when using my Philips DVD player, so have zipped the files as suggested.

There are 12 .IFO files and 1 x VIDEO_TS.VOB; but no VTS_0x_0.VOB from this set 1 rip.

I’ve uploaded zipped files to here for download [B]sg1_s9_d4_IFO.zip[/B] and examination by anyone who might be able to find the fault with them (1.2 MB)

meanwhile I’ll keep fiddling with the files myself, and trying different software to fix :confused:

Johnno


#9

I didn’t mean VTS_0[B]x[/B]_0.VOB literally. Substitute [B]x[/B] with a number, where there are menus. I don’t know where the menus are located. Sorry for being unclear. From the looks of it, the menu VOBs are VTS_02_0.VOB, VTS_03_0.VOB, VTS_04_0.VOB, VTS_06_0.VOB, VTS_07_0.VOB, VTS_08_0.VOB. Please zip these files up.


#10

'sok,
I’ll get to understand this eventually.

zipped 'em up

VTS_02_0.VOB, VTS_03_0.VOB, VTS_04_0.VOB, VTS_06_0.VOB, VTS_07_0.VOB,. are here [B]sg1_s9_d4-VOB.zip[/B] 3.3 MB

[B]VTS_08_0.VOB[/B] seems to be just a photo gallery and is here, but its 14 MB


#11

The menus display fine in all my dvd players and I’m able to navigate all through of them. Do you have a problem with only one dvd player, or all of them?

I have one dvd player that usually does not like still menu with open GOP - it would stop playing like what you’re experiencing. So I reauthor it with close GOP and this player displays it correctly. The strange thing here is that all of your menus are open GOP and I’m surprised that my player can display it, so it must be something else.

Anyway, I’m going to try 2 ways:

  1. I only change the ‘episodes’ menu (where it lists all 4 episodes) to have close GOP. Replace this VTS_02_0.VOB (http://www.savefile.com/files/1582102) over the ripped files and see if your player likes it.

If this doesn’t work, then try this second method:

  1. I reauthor the ‘episodes’ menu with MuxMan, which will automatically put close GOP and have a less number of video packs, thus the reduce file size. Replace this VTS_02_0.VOB (http://www.savefile.com/files/1582107) over the ripped files. Then open VTS_02_0.IFO with IfoEdit and select ‘Get VTS sectors’ and ‘Yes’. Let’s see if your player likes it now. It should though.

I prefer not to redo all problem menus with second method as this is tedious task.


#12

Hmmm,
tried method one, same result.

downloaded IfoEdit and did as sugested with method two; but when I went to burn disc with CloneDVD2, it had a problem?

after selecting video source, and then moving to next page, the quality status bar filled briefly, then it was empty ?? restarted process,same thing happened.

so I just continued to next page where a popup said it was trying to repair faulty DVD structure - so I let it do what it had to, it then started the usual collecting and compressing of video files before burning to disc.


#13

Toaddub,
second method worked, tested it twice in each of two DVD players and the episode menu appears, is navigable, and selectable :smiley:

you’re a champ and a legend; but why was this disc so different from the other 53 discs in the set ???

so what was it you did with this Muxman to fix this disc, and which version did you use
http://www.mpucoder.com/Muxman/versions.shtml


#14

Glad it works. :slight_smile: I suspect method one does not work as it’s not the correct way to patch things up. So the episodes menu is the only one that has problem? If so, that is odd indeed. I don’t know why it’s different, probably due a minor improper menu authoring.

I used the Muxman Pro version but the free version will do. Actually I use more programs than MuxMan for method 2. I first extract the menu background with VobBlanker and the 2 subpicture highlights with PgcDemux by vobid. Then mux the background and the 2 subpics with MuxMan, choosing 16:9 dislay, into a VOB file. Now it’s time to export the buttons and the color schemes of the original menu for safekeeping using DvdReMake Pro. Then replace the newly muxed menu over the existing menu in DvdReMake Pro and import the buttons and color schemes back in. You can also do the export/import of buttons and color schemes and replacing menu with PGCEdit as an alternative.

And that’s it.


#15

Ah ha
I’ll have a go at duplicating what you have done and see if I can fix another copy of the rip so it works as well, just to ‘nut’ it out as such.

thanks people :slight_smile: