Severe issues with my Drive

vbimport

#1

Baught a DW-D23A drive not long ago and all was good all was fine…
Few weeks back it just decided not to write to blank cds/dvds… tried all formats although my drive supports em all so i started reading around found out about firmware an all this stuff things i didnt realise before…
So i started trying recommended firmware flashes and it would either not work or would be a little bit better by writing cd’s, still not dvds…
so yesterday i was trying another flash i saw off another site and my computer restarted itself mid flash…
so now i have a non-firmwared drive and my windows wont detect it and i cant flash it to something else…

Anyone know what i can do about this?

Also if anyone can solve this AND email me the CYS1 firmware i would be v v v v v much in debt to them

  • May i add ive tried system restoring to a day that it worked and some reason it just wont let me, the restore comes back incomplete and im stuck within this week frame.

Also tried to Sysrestore to yesterday when i had a drive with firmware installed and it didnt change nothing to the drive ;[


#2

— by Code —

If your drive is not seen by Windows then you will need to use MTKFlash to restore it.

This is the procedure I recommend (if your drive is a 1673S):
1/ create a bootable dos disk. Remove all files except command.com, io.sys and msdos.sys (the system ones)
2/ download mtkflash 1.80 from http://dhc014.rpc1.org/howto.htm
3/ Add MTKFlash.exe to the disk.
4/ Get JS07.BIN from http://codeguys.rpc1.org/firmwares/stock/1673S.JS07.stock.rar.
5/ Add this to the disk.
6/ Select the jumpers on your drive for master and remove all other drives.
7/ Boot to the floppy while holding the drives eject button.
8/ Type in MTKFlash 3 w /b /m JS07.BIN. The 3 is secondary master. See the step 2 site for details.

The drive can also have it’s IDE lead plugged in after the boot to DOS if the system hangs during boot up. Make sure you still hold the drives eject button while the drive is powering up.

— by Code —

^^ simple example =]