Severe 716A DMA problems

vbimport

#1

I’ve been having DMA problems with my 716A since I took it out of the box. The drive will simply not function in DMA mode, it freezes the OS when you put in a disc until you eject the disc. I’ve gotten the drive to work in PIO mode, but what’s the point of having a $130 drive if I have to use it crippled? <_<; I have the latest firmware, newest version of Plextools, and both of my hard drives are functioning in DMA mode right now, so I don’t think it’s my mobo. Someone please help, this is beyond furstrating. ;-;


#2

What OS, motherboard, chipset, CPU are you using? There is a new firmware 1.04 updated only on the European Plextor site that fixes problems with motherboards - have you tried it?


#3

I’m running XP Pro SP2 on a Shuttle XPC SB65G barebones mobo, with an intel chipset driver and a P4 2.8gHz HT CPU. Just tried the new firmware, didn’t work. :\


#4

…Wow, they literally posted a new firmware upgrade on the asia website just this morning. o.o Gonna see if that does anything…


#5

Oh, wait, they just renamed the European update as TSC for some reason. ><


#6

Are you using the cable that came with the Plextor and tried it on the end of cable set as Master with no slave drive?


#7

You say the Plextor freezes your OS using DMA is that DMA 2 or 4??? With my intel chipset I had to set the DMA to 2 for it to work properly. If you can’t find a way of changing the DMA in the BIOS try using a 40 pin IDE cable. I have just updated the 716’s firmware to 1.04u and this seems to have solved a few more problems with motherboard compatibilities… I can now run the 716 in DMA 4 mode on a Nforce4 chipset.


#8

I’m running it at four, but you know you can make it run at two just by putting a jumper on the DMA pins next to the Master/Slave/CS jumpers. o.o I did try that, with the same results. ;-; By the way, to be really specific, I’m running an 865PE Intel chipset, I just updated the drivers for that and that didn’t help either. ><


#9

Well, I tried using the cable that came bundled with the drive just for the hell of it, and of course that didn’t make a difference, but I did figure out that I was using a 40 pin IDE cable for both of my ATA100 drives, and quickly replaced it an 80 pin cable, yey for cheap performance enhancements. :smiley: Still don’t have a clue about the 716A issue, though, I’ve tried absolutely everything I can imagine.


#10

Just a thought! But delete Sonic DLA and INCD then if that doesn’t work =delete your drives in device manager/reboot/reinstall/check your Bios settings!


#11

Tried that too, still nothing. x_x I’m really frustrated that I spent all this money on the best drive I could find, and there’s nothing I can do to get it to work correctly. Still hoping someone knows what to do…


#12

At this point, I think that the best thing is to test the drive on another PC, to see if it is broken and, in case, RMA it…

ET


#13

I did try it on another PC, got the exact same problem using UDMA mode. Not even the Plextor tech support seems to have any idea what to do about this, but I don’t think they want to give me an RMA…