Setting Drive letter

Somehow my DVD and CD-ROM changed from E: and F: drive letters to M: and N: drives. I replaced the CD-ROM with an NEC ND-3550 and it reset itself to F: just like it should be. WINXP SP2, HP Pavilion a450n. I have Alcohol 120% on my computer also but the virtual drives are Y: and Z:. Question: how do I reset the other DVD drive from M: to E: I tried disconnecting the power from the drive, rebooted, reconnected power, still comes up M:
REGARDS, gamma1

Hi and welcome to th forum :slight_smile:

Go to control panel --> Administrative tools --> Computer management

From here select “Disc management” from the list on the left panel, and then select the drive you want to change letter, right click in it in the point shown by the red arrow (if you do right click in a different point the menu will not appear).

Finally, select “change drive letter”


Start -> All Programs -> Administrative Tools -> Computer Management.

Click Disk Management, then right-click your drives and click Change Drive Letter and Paths.

I’ve had to do this myself…I’m using XP Pro though, not sure if you can do it that way in XP Home.

:slight_smile:

Edit: Hahahahaha, Geno beat me to it :bigsmile:

thanx, That was a fast reply, and it works with WINXP home. Cheers, gamma1

You’re welcome

:stuck_out_tongue: @ [B]Arachne[/B] :bigsmile: :flower:

Yes you can do it in XP Home also, and MCE also. I also use XP Pro SP2 but my son has HomeEdition

Ah, thanks :slight_smile:

You’re welcome, gamma1 :slight_smile:

Aaaauuuugg! I just added a BenQ DW1650 to my same system above and it assigned the BenQ as drive M: instead of drive E: which is where my old HP DVD drive was. Well, I thought, I know how to fix that. I went to the disk management and clicked on drive M: to change drive letter and paths but E: does not appear as a choice. E: does not appear in Windows Explorer either. Any ideas about how I can get this showing as drive E: …regards, gamma1

move the drives after D:\ up one letter so E becomes F and so on then E will be a choice

The problem solved itself. E: appeared (maybe when I rebooted again?) when I tried the procedure again. Thanks, Happy again, cheers, gamma1.

Did someone post a while about reg hack that made you able to name the optical drive label ?

yup!

http://club.cdfreaks.com/showthread.php?t=118531

Cheers reasonsnotrules, I could not remember what was in the post and my searches were not working :smiley:

Same problem occurred again!:eek: I just upgraded firmware on DW1650. Upon reboot it turned into the M: drive and E: was not an available choice in WINXP disk management. Odd thing is, Nero Info Tool and a few other programs still showed it as E: Nevertheless, I rebooted a second time and was able to update M: to E: in the WIN disk manager. So in my system anyway, it takes two reboots to get everything squared away… cheers, gamma1

There is a neat little script that will allow you to change the optical drive labels. You don’t need to know beans about registry editing. Just type the desired name in the box. It’s item number 191 here:
http://www.kellys-korner-xp.com/xp_tweaks.htm

It’s actually simpler than Kelly knows. The script says you need to log off for the name change to take effect. All you really need to do is open another Windows Explorer, and there it is.