Serious Record Buffer Level Fluctuations

Hello, This might seem a bit long, but I thought I should include everything I have encoutered to hopefully make it easier for all of us :slight_smile:

I’ve been experiencing this strange situation lately, and haven’t been able to come up with anything concrete via google or here. Ok, so here are the facts… I am running a Toshiba Satellite PIII 850Mhz, 256MB Ram laptop running Windows XP Pro. I am using a USB 2.0 PCMCIA Adapter which is linked to my external Plextor 40/12/40U Burner. The software I am using is the Plextor issued Nero 5.5 Burning Rom, with firmware uptdated on the Plextor.

I have been using this burner for a few months, and everything has worked perfectly. Over the past few weeks… out from no where… when recording CDRs(which are capable of 48X) @ 40X(6000kb/s)… let us say for example a ~700MB disc would take over 20 mins. Usually it only takes betw/ 5-6mins. I have tried reducing the speed but to no avail, same situation. :frowning:

I have also checked to make sure that the lens is not dirty, the connections are correct. The only thing I have noticed is that my Recording Buffer Level has been changing constantly during the buring process anywhere between 5-95%. :eek: Usually and almost always… my record buffer level stays at 96-98%!!

I also have tried closing all applications, disabled net connection, made sure no major processes are going on (i,e, in the system taskbar)… but nothing has changed. Device manager indicates no connection problems (i.e. drive is recognized, as well as USB 2.0 connection, no exlamation marks

Also, I am not sure about this… Someone has mentioned about viral infection? Can a remnant of something called “WWIN32” be still on xp, even after norton av 2003 check (w/ the latest definitions) states no infections found? I did an online check at PC-Trend/PC-Cillin… no infections found. Scandisk and Chkdsk had found no problems.

Possible Fragmented hdd? I have no idea… any advice or suggestions would be greatly appreciated because I am totally lost here. Many thanks for your time and help!!! Take care.

-MrClark

Defragmenting your hard drive would definitely be a good idea, but it is probably not causing the problem here. It’s worth a try, though.

When the buffer is fluctuating like you mentioned above, is your CPU usage very high? You can find this out by watching the CPU usage indicator on the Performance tab of Task Manager while you burn. You can open Task Manager by pressing Ctrl-Alt-Delete.

Hi CDRecorder, Ok… I did what you asked. I’m not too sure on the diagnosis, but here it is:

While burning a 665mb cdr Data disc, I noticed that while the “Record Buffer Level” kept jumping from 4%-20%-50%-95%-40%-35%-12%-20%-10%-50%-25%-etc.etc.etc… and everything in between constanstly throughout the entire session. It would never stay the same… always jumping.

[u]CPU usage[/u]: was going almost always from 93%-94%-96%-87%-100%-97%-98%-100%… [i]almost the entire time hovering over on average in the upper 95’s-100% range.[/i]

Here is the data from my burn session:

ISO MODE 1
CDROM ISO 665MB Data ~75some minutes

[u]4:27:47PM[/u] PLEXTOR CD-R PX-W4012A BURN PROOF ACTIVATED
4:27:47PM Caching of Files Started
4:27:47PM Caching of Files Completed
4:27:47PM Burn Process Started at 40X (6,000 KB/S)

4:40:40PM Burn Process Completed Successfully at 40X(6000KB/S)

4:40:57PM Data Verification Started
4:53:25PM Data Verification Completed Successfully

:confused: :confused: :confused:

Normally, the process of burning the above mentioned disc size would take <6-7 minutes and verification usually a few minutes. So basically a little below 10mins total a CD. I have never seen the process go near 16 mins till now… and mind you that it’s not even a full 700mb disc. There’s something strange going on with this record buffer level. In all my burning days, I have yet to see such a jump in buffer recording. As I’ve said before, it’s always stayed in the upper 95-98% range… well, till now that is :slight_smile:

I hope this information can help diagnose my situation. I had no processes running, Norton AV was disabled, wasn’t using my net connection. I really don’t understand what’s going on here :eek:

Again, thank you for your feedback. :cool:

-MrClark

is dma enabled for all drives?

Although a USB drive probably doesn’t have a DMA setting, the hard drive will.

The first thing I would check is that DMA is enabled for your hard drive; you can find directions to enable it here.

Hey AZimmortal - I checked out my IDE controller… and PIO mode is the transfer setting enabled. I have an intel chipset on my laptop… and downloaded the new INF files… but it hasn’t changed anything… DMA setting has always been disabled or off…burning worked awesome. I haven’t changed any settings afterwards. I know a lot of people say to keep DMA on, but I can’t turn it on anyways for some reason.

Also tried burning a 630 mb data disc just a little bit ago…

started at 9:30pm, burning ended at 40x at 9:47pm… heh.
verification started a few seconds later and then ended at 9:59pm. This was while doing other things though… searching the web for example.

i suggest u edit ur post to remove that whole list, cuz that info’s not relevant. as for the dma problem, i’m sure dma used to be enabled, but winxp reverted back to PIO after it encountered too many ide errors. if ur hard drive isn’t operating in dma mode and setting it to “dma if available” doesn’t work in getting it to run in dma mode, i’m not sure there’s much u can really do since the usual remedy for a drive that refuses to run in dma mode is to delete the controller it’s installed on, rebooting, then letting windows reinstall it; however, i don’t think u’re supposed to delete the controller that windows is installed on. the only option i can see now is to format, but maybe someone else has another idea.

Let me ask you a question, When you reboot your pc, does it hang with the dma enabled?? You can manually go and change the dma settings by going to device manager. What you have to do is to, device manager, switch the dma manually, switch it back and then it should see it as enabled. If it says pio, try switching to dma, then close that window, go back to the ide controller and see if it dma whatever(whatever being whatever mode it is). Try it for all the channels. This might speed up the burn, because it 48 or 40x it shouldnt takle that long to burn a cd.

Originally posted by AZImmortal
i i’m sure dma used to be enabled, but winxp reverted back to PIO after it encountered too many ide errors. if ur hard drive isn’t operating in dma mode and setting it to “dma if available” doesn’t work in getting it to run in dma mode, i’m not sure there’s much u can really do since the usual remedy for a drive that refuses to run in dma mode is to delete the controller it’s installed on, rebooting, then letting windows reinstall it; however, i don’t think u’re supposed to delete the controller that windows is installed on. the only option i can see now is to format

Thanks for the input AZimmortal, My Laptop is running a FAT32 Drive, with my OS and everything else on drive C:.

When I selected the link CDRecorder gave, I read the article FAQ on how to enable the DMA. Everything you have mentioned above is totally correct. Although I am not sure if DMA was ever enabled on my system. Anyways, I can’t switch to DMA for some reason.

RIght now and how it always has been for the last year:

[b]

Intel® 82801BA Bus Master IDE went to intel’s site, downloaded the new INF chipset files, but I haven’t noticed anything different after installing them

==============================
Primary IDE Channel:

Device 0
Device Type : “Auto Detection” faded out
Transfer Mode : “DMA if Available” other option is:PIO ONLY
Current Transfer Mode : PIO MODE

Device 1
Device Type : “Auto Detection” other option is:NONE
Transfer Mode : “DMA if Available” other option is:PIO ONLY
Current Transfer Mode : Not Applicable

Secondary IDE Channel

Device 0
Device Type : “Auto Detection” other option is: NONE
Transfer Mode : “DMA if Available” other option is:PIO ONLY
Current Transfer Mode : Not Applicable

Device 1 same as Device 0 in Secondary IDE Channel

----------------------------------------------------[/b]

I’ve always been burning in this mode for a long time… so I am not sure about the DMA being the culprit… but hey what do I know:)

I’m nearly 100% sure that the problem is DMA. Without DMA enabled, your computer won’t be able to transfer data nearly fast enough to burn at 40x.

Check out this article, which explains how to resolve problems with DMA in Windows XP. This is a different article than I provided above.

Transfer Mode : “DMA if Available” other option is:PIO ONLY
Current Transfer Mode : PIO MODE

as u can easily see from the first line, dma mode was enabled by default. however, winxp reverts back to PIO mode if runs into too many ide problems while using dma mode and won’t let u switch back to dma without deleting and reinstalling the controller.

Hello MrClark , you have Intel Chipset in ur laptop, right . so IDE controllers should be Intel too . why don`t u try installing Intel Application Accerator which is available in downloads ( intel.com ) . get the latest version. hope u get DMA running fine

Arun

Originally posted by MrClark
[B]Hello, This might seem a bit long, but I thought I should include everything I have encoutered to hopefully make it easier for all of us :slight_smile:

I’ve been experiencing this strange situation lately, and haven’t been able to come up with anything concrete via google or here. Ok, so here are the facts… I am running a Toshiba Satellite PIII 850Mhz, 256MB Ram laptop running Windows XP Pro. I am using a USB 2.0 PCMCIA Adapter which is linked to my external Plextor 40/12/40U Burner. The software I am using is the Plextor issued Nero 5.5 Burning Rom, with firmware uptdated on the Plextor.

I have been using this burner for a few months, and everything has worked perfectly. Over the past few weeks… out from no where… when recording CDRs(which are capable of 48X) @ 40X(6000kb/s)… let us say for example a ~700MB disc would take over 20 mins. Usually it only takes betw/ 5-6mins. I have tried reducing the speed but to no avail, same situation. :frowning:

I have also checked to make sure that the lens is not dirty, the connections are correct. The only thing I have noticed is that my Recording Buffer Level has been changing constantly during the buring process anywhere between 5-95%. :eek: Usually and almost always… my record buffer level stays at 96-98%!!

I also have tried closing all applications, disabled net connection, made sure no major processes are going on (i,e, in the system taskbar)… but nothing has changed. Device manager indicates no connection problems (i.e. drive is recognized, as well as USB 2.0 connection, no exlamation marks

Also, I am not sure about this… Someone has mentioned about viral infection? Can a remnant of something called “WWIN32” be still on xp, even after norton av 2003 check (w/ the latest definitions) states no infections found? I did an online check at PC-Trend/PC-Cillin… no infections found. Scandisk and Chkdsk had found no problems.

Possible Fragmented hdd? I have no idea… any advice or suggestions would be greatly appreciated because I am totally lost here. Many thanks for your time and help!!! Take care.

-MrClark [/B]

Hey guys, just dropping in to let you all know everything is working again!!! :smiley: :smiley:

I really would like to thank all of you who participated in this thread for your insight and suggestions. I really was outside the track on this one. no pun intended :stuck_out_tongue:

So these are the steps I did for future reference…


  1. Defragmented my HDD using Diskeeper 8.0

  2. Read through the links given by CDRecorder above.

  3. Followed the instructions given at the bottom of this link:

http://www.microsoft.com/whdc/hwdev/tech/storage/IDE-DMA.mspx

  1. When to Device Manager> Uninstalled my Intel Chipset Bus Master IDE Controller.

  2. Windows asked me to reboot my laptop

  3. After reboot, Windows redected my IDE Controllers and Channels.

  4. Windows then asked for me to reboot my laptop

  5. Device Manager reads that the current transfer mode for my Primary IDE Channel is : [u][i]Ultra DMA Mode 4[/u][/i]

  6. I almost cried.


Ran Nero Burning ROM, switched on the Plextor, and to my joy… Record Buffer Level [i]never[/i] dropped below 97%!!! I am so relieved!!!

Again, thanks to all here at Club CD Freaks for their time and holding up a wicked forum!

Cheers!

-MrClark

You’re welcome, and I’m really glad to hear that everything’s working as it should again, MrClark! :smiley: