Serious problems with my new 80gb Raptor & nForce4 board, help!

To make a story short, there seems to be a major problem with my nForce 4 board and my new 80 GB Raptor. After 10-20 reformats trying to install Vista and XP Home on the last attempt, I was still unsuccessful with Vista Setup bringing up this error code while trying to format it, trying to create a partition or install it:

“Windows could not assign a drive letter to a partition on disk 1. The specified disk does not exist. The error occured while preparing the partition selected for installation.” Error Code: [0x80300025]

Then XP setup saying the disk may be damaged right after the partition was formatted. Anyway, I tried installing both Vista and XP in a completely different computer in my home and both OS’s installed and worked PERFECTLY with NO problems. I also encountered ZERO problems when I first installed XP onto my new 500 GB Seagate less than 2 months ago.

If anyone can help me with this problem which has had me aggravated for days, please do share, I’d really appreciate it.

P.S. - I’m using the latest nForce 4 drivers as well.

-Cyne