Secondary IDE channel won't reinstall

vbimport

#1

Hi, have been having problems burning DVD’s lately, the buffer would go up and down like crazy and the light on the drive would flash in rhythm with the Hard disc LED. Burns would also take longer than they used too.
I checked the IDE channels and noticed that the secondary master was set to DMA if available but was running in PIO mode so I deleted the secondary IDE channel and rebooted to see if it would reinstall.
However when I rebooted everything seemed to be picked up ok until it got to the end of the process then I get the message An error occurred and “Driver Not intended for this platform”.
Now I can’t seem to get the secondary channel to reinstall. My mobo is an ECS k7s5a and it has the SIS735 chipset.
I downloaded the IDE drivers from SIS but I am unsure how to install them as there is no exe file and when I try to update the IDE driver through the device manager I get the same mesage “Driver not intended for this platform”.
Please can anyone help me to resolve this as it’s very frustrating.
Thanks :slight_smile:


#2

i downloaded the ide driver from sis just to see what your talkin bout,there is definitely an exe file and is called SETUP.EXE


#3

I assume it’s trying to install a device named hdc. That’s when I got that message.
What I had to do was reflash the bios by getting the latest update from Gigabyte (my mobo).
You might be able to clear CMOS by a jumper on then mobo, alternatively disconnect all power & remove the battery for about 10minutes.


#4

I tried running the setup.exe file and got an error message, I can’t remember what exactly as I am on another machine at the minute, but I do remember it said “Cancel or Ignore” I tried both and nothing happened.
I’d like to avoid dlashing the bios if possible as everything else is running smoothly and I don’t want to mess anything else up.
Thanks.


#5

i doubt the bios got anything to do with it,anyway run the setup.exe again but this time take a screenshot and upload to http://www.imageshack.us/ and give a link
btw i recommend this prog http://www.gadwin.com/printscreen/ very easy to use & free


#6

Hi, I used a program called XPFix and after that the SIS IDE driver installed fine. I rebooted and XP detected the IDE channel and my 2 DVD drives but I still get this message, and the install doesn’t finish properly.


#7

If you have a pc such as compaq, dell, etc, you should have a driver cd that came with the pc. If not, you should only use drivers from the support site for your particular pc. Get the original drivers back if possible. Or, restore your pc back to where it was before you removed the ide channel.


#8

have a look at http://www.michna.com/kb/WxDMA.htm
search the page for “Driver is not intended for this platform” or just scroll down its nearly at the end,and next time you wanna uninstall an ide channel simply right click it and click uninstall do not uninstall the driver itself from the properties


#9

Aha, thanks for that link. I uninstalled Daemon tools and Alcohol and rebooted and so far so good everything seems to be ok.
Just got to try a burn so will let you know.
Thanks for all help.