SD2 games won't work :(

vbimport

#1

Hey!

I have a Samsung SC-152L reader and Plex 401240 writer. I can't play a SD 2.5X protected games. I have tryed Grandia 2, 2002 FIFA world cup, Italian Job and many more. All games are original. I haven't installed progs like deamon-tools or insektors (I have tryed with them, but still no luck). When I have installed the games and try to play them, like Grandia 2, startpicture flashes ones and then stop. It doesn't say anything like please insert correct CD.
I'm able to make backups from securom games and they play just fine, no need to use 'hide cd-r media' with clonecd.
Only the SD2 games hangs :frowning: Can anyone help me?

using AMD1000 and Win98se

Thanks,
FinBastard


#2

Hi there, I had a same problem a while ago. I used my LiteOn16102b to write the games eg Command & Conquer Renegade but could not install them using that drive.

I was told that if I used my CDrom or DVDrom to install and play the game this would work. The reason being is that the drive checks for ATIP info ie Manufacturer of disc etc which only a CDRW can provide. As CD/DVD roms cannot do this the games install and play with no problem.

Hope that helps!!

chrome :slight_smile:


#3

SAME HERE!

Only the new versions of SD2 won’t work on my system

SafeDisc v2.05.XXX works on my system (THPS2), BUT FIFA 2002 (v2.40.010), MOHAA (v2.51.021) will NOT work. I get the exact same problem - splash screen flashes for a couple of seconds, then dissapears!

This happens on the original CD’s as well as perfect backups, and I am unable to find the cause. I’ve even applied the latest updates to the games, reinstalled my NVIDIA 128MB DDR GeForce3’s Detonator XP drivers (28.32), reinstalled VIA 4in1’s and heaps of other things.

Tried the games in the following:

Lite-On DVD-ROM LTD-163 (GH5K)
Teac CD-W54E (7.1F)
Sony CDU-4811 (PY0A [I think?])

All failed, same problem.

System:
IBM Aptiva
Intel Coppermine Pentium 3 733MHz
Via Core:
North Bridge VT82C694X
South Bridge VT82C596B
128MB SDRAM with 133MHz FSB
Maxtor 15GB Hard disk
Leadtek WinFast GeForce3 Titanium 200 TDH 128MB DDR-SDRAM (Latest 28.32 drivers)
IBM E74 17" Monitor
Teac CD-W54E
Lite-On DVD-ROM LTD-163
Windows 98 Second Edition (also!)

Fin, maybe we both have same componet/s on our systems that is causing this

Any ideas anyone

I’m at amaze on this…
Might be something backlisted on my system (remember one CloneCD 3 version was blacklisted in FIFA 2002, and the game wouldn’t start!?)

PLEASE HELP US!

Thanks alot for your time

Oh @ Chrome307,

That is not possible because the games are pressed and as such, do not have Absolute Time In Pre-groove info. Only CD-R/RW media contain this. :wink:


#4

Yesterday I formated C: :slight_smile: and then installed WIN XP, now games works fine; originals and backups :smiley:

-FinBastard-


#5

I had this same problem with Operation Flashpoint (don’t know what safedisk version that it) and I asked the makers of the game why it was doing this. They told me that thir game, along with many other safedisk protected game, do searches of your HD during the splash screen for certain files and programs. These programs CAN include CloneCD, Daemons Tools, Morpheus. I couldn’t beleive this! Is that llegal? Well, anyways, if you have some of these programs installed or other “wierd” programs, try uninstalling them and then playing.

I found out that it wasn’t any of these programs creating my problem, but actually a .dll file installed by a program called something like safedisk-remover, a long time ago.

A format will 99% work.


#6

Wiz, I believe that 100%. I knew it was something that was blacklisted in v2.40> that was causing this. Or if that wasn’t the case, my SD v2.05 game wouldn’t have worked at all :eek:

So anyone got some “Macro illegall” programs that could be causing this conflict? CCD 4 can’t be one because there would be plenty of other people complaining that thier games won’t work. I doubt Morpheus would be one, that would have also surfaced by now…

I’ve never installed DAEMON tools ever on this machine, so thats out.

Anyone got some more ideas?

Or better still, anyone got the contact info for EA Games (E-Mail)? The two games affected are MOHAA (v2.51.021) and FIFA 2002 (v2.40.010).

Thank you for your time!

(I would like to avoid a format as much as possible :Z )

:wink:


#7

use reg cleaner and make sure any decompilers/emulators are totally gone…that should fix it, as safedisc 2.4 and up checks the registery


#8

Originally posted by ckin2001
use reg cleaner and make sure any decompilers/emulators are totally gone…that should fix it, as safedisc 2.4 and up checks the registery

Thanks. But can you tell me where to find the registry cleaner you mention :confused:

Cheers :cool:


#9

Originally posted by ckin2001
use reg cleaner and make sure any decompilers/emulators are totally gone…

Sorry to sound newbish but what are decompilers/emulators? I have a playstation emulator if that’s what you are tlaking about, but that still leaves decompilers.

Thanks.


#10

Have any of you guys got any details about which programs might be blacklisted by later versions of safedisk 2. There was a rumour that clonecd was on this, Daemon tools, playback and the list goes on but obviously most of the guys here run these things and have no problems.

This thing where original safedisk2 games crash to the desktop drives me nuts. It is looking more and more like a reformat and upgrading to XP may be in order.
I have tried taking all these possibly black listed programs off and I guess there may have been remnants left on the registry but still no dice. I have not been running any emulators which I guess is the most likely culprit.

If anyone knows for a fact that Safedisk blacklists programs could they name them…


#11

daemon tools, um, playbackup, almost any program that involves virtual mounting of images to play…hex editors, anything popular. honestly, if you get the message about having one, you should know what it is :wink:

clonecd is not blacklisted


#12

Thanks for that Ckin. The only one that I have put on since last reformat that might be causing probs is daemon tools so I will try and get rid of this again.
Last time it did not help and it is a pain as it is a great program.

Ckin do you know whether you need to take Daemon right off ( thru contorol panel etc) or I did see somewhere you can change the letter of the virtual drive.

Has anyone else had probs with safedisk 2 and daemon?


#13

safedisk is accessing a registry key, i beleive daemon may actually tell you how to get around this…although make sure you know what you are doing. registry’s are sacred, and changes may just be forever


#14

@ ckin2001,

THANK YOU VERY, VERY MUCH!!! :smiley: :wink:

daemon tools, um, playbackup, almost any program that involves virtual mounting of images to play…

Playbackup was STILL installed on my system form 10 months ago when I didn’t have SD2 compatible hardware.

SafeDisc was accessing the registry, because when I used RegCleaner, it was detecting CrazyCows - Playbackup, which when found, SafeDisc crashed the application. :stuck_out_tongue:

Smart people, but I wish Macro would put out a list of it’s “Blacklisted” programs :mad:

So any thing that can emulate/mount SD2 images/discs, will 99% be blacklisted :rolleyes: 

AGAIN, I would like to thank CKIN2001 for his very usefull advise, which I had completely overlooked previously :wink:

:cool:


#15

battleaxe, If you strongly believe it’s the DAEMON Tools causing you this prob, download the latest version (v3.11) here, as this will address the issue for the latest version of SD2 (Until another version comes out :mad: )

Update/Info:
“…Once again DAEMON Tools has been blacklisted by Macrovision. And once again we release a new version to get around this blacklist. Maybe one day they get tired playing this childish game…”

Here’s the complete changelist of DAEMON Tools 3.10:
CD-TEXT support added
Fixed CD+G support for all images (raw P-W and deinterleaved formats)
Fixed Securom emulation problem in some games
DVD support for DiscJuggler images (*.cdi) added
Driver renamed to stealth.mpd (95/98/ME) or stealth.sys (NT/2000/XP) to avoid blacklisting (eg. in Safedisc V2.60.xx)
Fixed compatibility issues with ZoneAlarm Pro and some other applications
Some minor bugfixes

:wink:


#16

I have the newest version of DAEMON Tools (3.02) and I play SD2 games fine.


#17

not a problem, its often the easiest things to check for that we dont think of. thats why the first thing a tech support person will ask you, about almost any product, is ‘is it plugged in’


#18

Thanks for help guys. I have now got latest Daemon running as of yesterday. The problem,I hope, is that I did have playbackup on my system from a long time ago which I had forgotten about.

Simply deleting this did not do any good. Had a look thru registry and could not detect any reference to playbackup but shall take plexys advice and search for crazy cow etc with reg cleaner.

Thank you for your advice guys and I hope that fixes up problem…


#19

I’m using latest update of Daemon Tools 3.02 with MOHAA which had been freezing at splash screen without Daemon Tools, but with the latest version of Daemon tools it works fine.

HP CD Writer Plus IDE 4x4x24 CDR/RW


#20

Originally posted by ckin2001
not a problem, its often the easiest things to check for that we dont think of. thats why the first thing a tech support person will ask you, about almost any product, is ‘is it plugged in’

The tech support person didn’t even ask me that question and he gave up :mad:

Hello Clint,

Thank you for sending your concerns regarding MOHAA.

If the game still will not run, unfortunately, I have no further suggestions for you at this time. We have exhausted all of the standard troubleshooting which can be done remotely, and at this point the game should be running properly but is not. This could be due to a hardware incompatibility, which we are not aware of, or simply a problem that was overlooked due to the nature of this correspondence. If you continue to troubleshoot your machine on your own and solve the problem, please drop us a line. If you would like to return the game for a shrink wrapped copy which you can return to the place of purchase, please send the entire game contents along with a copy of your original receipt to the address below:

EA Australia
ATTN: Warranty Replacements
46 Smith St.
Southport, Queensland 4215

When we recieve the package we will process it and send out a replacement as soon as we have it in stock.

Hopefully these suggestions will help resolve your difficulty playing the game.

Thank you for contacting EA Technical Support.

Timothy E.
EA Technical Support

Please include all previous emails (AOL users will have to cut and paste the contents of this email into their reply.) and refer to: http://techsupport.ea.com for more information. If you have found a solution other than what I have suggested, please reply with that solution so we can better serve our customers.

Anyways - Im going to tell him what I told him in the first place, IT WAS THE SD2 copy protection…